SOLVED - Mod Wheel Changing Presets in Komplete Kontrol Software

Scho33
Scho33 Member Posts: 5 Member
edited August 2022 in Komplete Kontrol

Hello All,

Since a few weeks (I cannot tell exactly) I have the problem that if I turn the Mod Wheel on the Midi Controller the Komplete Kontrol Software does not change the Mod Wheel / CC1 parameter but changes the preset / runs through the browser of KK...

The error occurs with other maufacturers controllers, e.g. Arturia Minilab as well as while using the KK S88 MK2 Hardware.

The error occurs in KK Software v2.7.2 Standalone as well as in the VST2 and VST3 versions in Ableton Live 11 (all Windows).

The Mod Wheel CC1 function works fine in e.g. Massive, Maschine Software (standalone / VST) as well as everywhere else where I tested it - so it seems to me being an issue in the KK Software routing the Midi CC1 into the browser :-(


Does anyone know the probelm or a solution?

(Deleting a configuration File or something similar?)


Reinstalling through native access (v1 and v2) did not solve the problem.

Also having only one controller connected to USB at a time didn't help.

I also tried to hide the Browser but the effect is still the same (changing the preset).

Best Answer

  • Scho33
    Scho33 Member Posts: 5 Member
    Answer ✓

    I just found the solution... I will still leave this in, maybe it helps somebody else.

    When the KK hardware is not connected (!) there is a "Midi" Button quite to the righthand side next to the BpM.

    If you click on it you can learn a midi function (click on "Buttons") for browsing the presets and I must have had it erroneously activated one day and then used the Mod Wheel...

    At the same place you can 'unlearn' the buttons. I did that now and it works fine again :-)

Answers

  • Scho33
    Scho33 Member Posts: 5 Member
    Answer ✓

    I just found the solution... I will still leave this in, maybe it helps somebody else.

    When the KK hardware is not connected (!) there is a "Midi" Button quite to the righthand side next to the BpM.

    If you click on it you can learn a midi function (click on "Buttons") for browsing the presets and I must have had it erroneously activated one day and then used the Mod Wheel...

    At the same place you can 'unlearn' the buttons. I did that now and it works fine again :-)

  • Nico_NI
    Nico_NI Administrator Posts: 1,125 admin

    Thanks for sharing @Scho33 💪

  • hardhal
    hardhal Member Posts: 1 Newcomer

    Thank you, searched hours for this and it completely solved my Problem!

  • XoNaR
    XoNaR Member Posts: 2 Newcomer

    Well done figuring this out, solved it for me also.

Back To Top