Cubase 12 / Komplete Kontrol S88 integration problem

ahcvankampen
ahcvankampen NetherlandsMember Posts: 7 Sine

Hi,

I am using Windows 10, Cubase 12, Komplete Ultimate 13 (latest version of Komplete Control 2.7.2) and have the Komplete Kontrol S88 controller.

When I start Komplete Kontrol (KK) as a standalone program I can browser/use/etc any virtual instrument from the S88 (that is, I see the instrument on the S88 display).

When I try from Cubase 12 I get weird behaviour.

1) I need to run the standalone KK software, otherwise the Komplete Kontrol DAW midi port does not show up, or if it is there, it will disappear after a minute or so.

2) If I add multiple Virtual Instrument track and load Komplete Kontrol on each of these tracks, then I can use the S88 to browse and select virtual instruments. Works fine. Also the DAW controls (play, stop, etc) work.

3) When I close and re-open the cubase project then for some reason the VI tracks are not recognized anymore by the S88. That is, I don't see the instrument on the display of the S88. It just shows the general midi screen (but I can still play the instrument from the S88)

4) Next, if a add another VI and load Komplete Kontrol, and select an instrument then this instrument I can again control from the S88. The previous add VI still don't show up.


Looking at the instruments, I see that the newly added VI has the S88 as Controller (see screendump) while the previous VI doesn't have the S88 selected (see screendump).


I also included 2 screendumps from the cubase studio setup.


Any idea what is causing this? How to solve? Thanks,

Antoine


Best Answer

  • ahcvankampen
    ahcvankampen NetherlandsMember Posts: 7 Sine
    Answer āœ“

    Dear all,

    Thanks for the replies. The solution turned out to be simple (of course šŸ˜Œ). I unstilled the driver and and the komplete kontrol software from Settings --> Apps. Next I reinstalled, and now everything seems to work.

    A

Answers

  • Brad Yost
    Brad Yost Anacortes, WA, USA Member Posts: 204 Saw

    Confirm that you have set up Cubase so that the S88 is an input MIDI device [Komplete Kontrol -1 driver] (for playing notes & track/instrument focus) and a separate setup as a Control Surface [Komplete Kontrol DAW-1 driver] and see if that helps.

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,353 Pulse

    Based on the screenshots the OP posted, everything appears to be set up correctly for both midi and Daw control. The issue here appears to be the problem mentioned in Bullet point #1ā€¦

  • Brad Yost
    Brad Yost Anacortes, WA, USA Member Posts: 204 Saw
    edited August 13

    @Blindeddie

    So is it possible that Cubase is not accepting the instrument (or KK wrapper) focus? [I haven't used Cubase for years, so pulling from sketchy memory here...]

    {OP screenshot of Midi Setup (pic#2) was only placeholder until third refresh on my browser, that's why I didn't see it}

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 1,353 Pulse

    @Brad Yost

    I just ran a test here (using an M32) with the same OS/Cubase/KK versions and everything works as expected, The fact the OP is having issue with the KK Daw driver makes me think that is the culprit...

  • ahcvankampen
    ahcvankampen NetherlandsMember Posts: 7 Sine
    Answer āœ“

    Dear all,

    Thanks for the replies. The solution turned out to be simple (of course šŸ˜Œ). I unstilled the driver and and the komplete kontrol software from Settings --> Apps. Next I reinstalled, and now everything seems to work.

    A

  • Arnaud88
    Arnaud88 Member Posts: 1 Noise

    If you still have Komplete Kontrol Autofocus problem in Cubase, try this:

    https://forums.steinberg.net/t/komplet-kontrol-no-kontrol-on-cubase-12/802157/4?u=arnaud88

Back To Top