Maschine 2 VST not playing notes from C#1 to D#2 in DAW

13_wicked
13_wicked Member Posts: 7 Sine

When running Maschine 2 as a VST3 in Studio One 5, the specified note range plays properly on my Maschine MK3 but not when played back in the DAW. Said notes will play a very brief attack and suddenly stop. So far this issue seems to occur in all groups regardless of instrument.

Best Answer

  • 13_wicked
    13_wicked Member Posts: 7 Sine
    Answer ✓

    I have finally found the solution to this problem thanks to the help of Flo from NI Support.

    My long winded explanation from the support conversation:

    I remembered I had a license for Cubase and tried replicating the project in there, but the problem was still occurring.


    I also realized that this is not a VST3 specific issue like I originally thought. Under Group Midi Input Settings, D-One has Start Note set to [C1]. On the VST2 version of the project, I had this set to [C-2].


    I went back and tested the VST2 template again, and the issue occurs there from C#-2 to D#-1.


    I checked the maschine 2 software manual and the following explanation is provided for the Start Note setting:


    "Define the MIDI root note for that Group (C1 by default). The MIDI root note and the upper 15 MIDI notes (from [Root Note] until [Root Note + 15]) will trigger the root note of Sound slot 1–16, respectively. Incoming MIDI notes outside this range will be ignored by the Group.


    The Start Note parameter is also used when importing a single-channel MIDI file to the Group — see section Importing MIDI to Patterns for more on this."


    So to put it more simply, the issue has to do with this setting.


    If you look at the VST3 version of the project where I have start note set to [C1], the note range that I am having problems with is C#1 to D#2 which are the 15 notes above C1.


    In the VST2 version, where start note is set to [C-2], the problematic range is C#-2 to D#1. Again, these are the 15 notes above C-2.


    I don't think there is any way to disable this 16 note range from triggering the other sound slots, so it seems the best solution is to set start note for these groups to [C-2]. I don't think there are many, if any, instruments or synths that I have that would need to use this low of an octave range.

    Flo's much better, simpler explanation:

    I found it is related to the actual mapping of the loaded Group. So in case you trigger sounds inside the Piano Roll of the DAW, there is a particular range in which sounds can be triggered. Since you have 16 Pads to trigger - those are available in a certain range of keys spread over multiple octaves - but a lot more keys in the piano roll, not all of the keys will trigger a sound/pad.

    So basically, set the start note to [C-2] rather than [C1] for all groups that use the settings listed in "Bass Group B1".

Answers

  • D-One
    D-One PortugalModerator Posts: 804 mod

    How are you recording the MIDI to DAW? Are you using MIDI drag-and-drop from MAS to Studio One?

  • 13_wicked
    13_wicked Member Posts: 7 Sine

    Hi D-One,

    I am using a template I made based on your (extremely useful!) guide to routing Maschine in Cubase to record midi straight into the DAW. I have the settings for Groups A1-H1 matched to the ones you have outlined in "Drum Group A1", while the settings for Groups A2-H2 are matched to "Bass Group B1". Groups A2-H2 are the problematic ones.

  • D-One
    D-One PortugalModerator Posts: 804 mod

    oh, so you're recording directly from Maschine to the DAW?

    The "brief attack and suddenly stop" sounds like a feedback loop of some sort, double-check if "MIDI Thru" is disabled.

    Upload the the zipped S-One project and I can try to have a look at what's going on, if you're using anything private oors custom sounds/samples/instruments remake it without those.

  • 13_wicked
    13_wicked Member Posts: 7 Sine

    MIDI Thru is off for all groups.

    All of the groups will be empty when you load the project, since I use this as a blank slate for my projects.

    If you have Razor, the "Subatik" preset is a good one to test the problem with.

  • D-One
    D-One PortugalModerator Posts: 804 mod
    edited July 7

    For your all Instrument Groups set: Sound > Output > MIDI to HOST, that should fix the problem, you also don't need to mess with transposition in the Instruments Groups.

    Also, deselect all the Pad's and just have Pad-1 pre-selected for a tidier template.

    Let me know if it fixes it for you.

  • 13_wicked
    13_wicked Member Posts: 7 Sine

    Thanks for pointing the pads out, I forgot to do that before.

    However, all of the groups already have those settings set like you wrote. Do they show differently for you?

  • D-One
    D-One PortugalModerator Posts: 804 mod

    Sorry my bad, I wrote it wrong, it's actually Sound > INPUT > MIDI to HOST .

  • 13_wicked
    13_wicked Member Posts: 7 Sine

    Unfortunately it's the same situation, they're already set that way.

  • 13_wicked
    13_wicked Member Posts: 7 Sine

    It seems this may be a VST3 specific issue.

    I found my VST2 version of the project I made a couple of days before the VST3 version released, and the C#1-D#2 range plays without any problems.

    There shouldn't be any difference in settings between these two as I copied the settings from the VST2 version when making the VST3 project. I've compared them both and so far I can't find any mistakes I might have made in the VST3 version.


  • 13_wicked
    13_wicked Member Posts: 7 Sine
    Answer ✓

    I have finally found the solution to this problem thanks to the help of Flo from NI Support.

    My long winded explanation from the support conversation:

    I remembered I had a license for Cubase and tried replicating the project in there, but the problem was still occurring.


    I also realized that this is not a VST3 specific issue like I originally thought. Under Group Midi Input Settings, D-One has Start Note set to [C1]. On the VST2 version of the project, I had this set to [C-2].


    I went back and tested the VST2 template again, and the issue occurs there from C#-2 to D#-1.


    I checked the maschine 2 software manual and the following explanation is provided for the Start Note setting:


    "Define the MIDI root note for that Group (C1 by default). The MIDI root note and the upper 15 MIDI notes (from [Root Note] until [Root Note + 15]) will trigger the root note of Sound slot 1–16, respectively. Incoming MIDI notes outside this range will be ignored by the Group.


    The Start Note parameter is also used when importing a single-channel MIDI file to the Group — see section Importing MIDI to Patterns for more on this."


    So to put it more simply, the issue has to do with this setting.


    If you look at the VST3 version of the project where I have start note set to [C1], the note range that I am having problems with is C#1 to D#2 which are the 15 notes above C1.


    In the VST2 version, where start note is set to [C-2], the problematic range is C#-2 to D#1. Again, these are the 15 notes above C-2.


    I don't think there is any way to disable this 16 note range from triggering the other sound slots, so it seems the best solution is to set start note for these groups to [C-2]. I don't think there are many, if any, instruments or synths that I have that would need to use this low of an octave range.

    Flo's much better, simpler explanation:

    I found it is related to the actual mapping of the loaded Group. So in case you trigger sounds inside the Piano Roll of the DAW, there is a particular range in which sounds can be triggered. Since you have 16 Pads to trigger - those are available in a certain range of keys spread over multiple octaves - but a lot more keys in the piano roll, not all of the keys will trigger a sound/pad.

    So basically, set the start note to [C-2] rather than [C1] for all groups that use the settings listed in "Bass Group B1".

Back To Top