M32 Kontrol Keys not sending midi in Logic Pro

StJm9999
StJm9999 AustraliaMember Posts: 3 Noise
edited July 14 in Komplete Kontrol

Any Ideas anyone

Tagged:

Best Answer

  • StJm9999
    StJm9999 AustraliaMember Posts: 3 Noise
    Answer ✓

    Hi

    Solution! I shall post here so it may help others

    In my control surfaces - somehow my Behringer xtouch one, had been labelled Kompete controller M32

    I deleted this one and then Logic picked up the keyboard properly again. All working back to normal!

    I found this by checking each control surface in 'control surface setup' and looking at device details.

    Logic Pro> Control surfaces>setup

    Click on each device and check the details

    A control surface (not a keyboard) had module and model labelled as Komplete controller

    To delete the wrongly set up device

    Make sure its selected then up to the top right

    Edit> delete> happy days

    All the best

    St John

Answers

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 1,718 mod

    So, this Mac Mini is a M1 computer ? Are you running Logic in Rosetta mode ? How to Open Your DAW Using Rosetta

  • StJm9999
    StJm9999 AustraliaMember Posts: 3 Noise

    Thank you for quick reply

    No its a 2 year old mac mini Intel i7

    They keyboard has been working perfectly for a couple of years, up to now!

    The problem was there before I upgraded to Monterey

    and before upgrading Logic pro

    I'm wondering if its a simple setting in Logic Hui or Mackie thing but I don't know how to change that.

    Cheers

  • StJm9999
    StJm9999 AustraliaMember Posts: 3 Noise
    Answer ✓

    Hi

    Solution! I shall post here so it may help others

    In my control surfaces - somehow my Behringer xtouch one, had been labelled Kompete controller M32

    I deleted this one and then Logic picked up the keyboard properly again. All working back to normal!

    I found this by checking each control surface in 'control surface setup' and looking at device details.

    Logic Pro> Control surfaces>setup

    Click on each device and check the details

    A control surface (not a keyboard) had module and model labelled as Komplete controller

    To delete the wrongly set up device

    Make sure its selected then up to the top right

    Edit> delete> happy days

    All the best

    St John

Back To Top