Missing Komplete Kontrol DAW-1 Driver

eeZSloW Member Posts: 4 Member

Gday Everyone,

Recently purchased a Komplete S49 MK2 and loaded everything up on a all new NUC9i9, Windows 11, Cubase 12 Pro, M-Audio 192/14 Interface and worked great for 2 days. Fresh install of everything.

I first encountered the freeze screen on the Controller at power on/boot up which searched for a fix and did the usual checking of running processes etc which all where running and the controller worked with lights and sound on cubase screen but no access viewing anything on Komplete screen.

Checked in Cubase Midi settings and noticed the Komplete Kontrol DAW 1 Driver was not listed anymore.

Uninstalled Komplete Software, along with both Driver packages, M-Audio Drivers, Cubase then rebooted PC.

Installed Cubase 12, M-Audio Drivers, Komplete Drivers, Komplete Software. Reboot.

I still cannot see the “Komplete Kontrol DAW 1 Driver in Cubase. But have the other 2 drivers showing in both Komplete Kontakt and Cubase and services are all running, just no DAW 1 Driver.

The problem I have is that I now have no lit “Mixer” button to show my track volume levels, and I know the 4D joystick doesn’t respond either. i can scroll through the menus in Cubase and see them on Controllers screen so it’s like the Browser , Plug-in , Instance, MIDI, Setup Buttons ‘work’ but the “Mixer” button does not.

The only thing I can find is from this older thread; https://www.native-instruments.com/forum/threads/missing-komplete-kontrol-daw-1-driver-massively-confused.312734/

Rebooting the PC does not fix it, I’ve tried uninstalling in different order/reinstalling in different order, I’ve tried what I can think of to no avail.

However I did find this In Regedit so maybe it could be a simple modifying of a few strings/things?. I’be spent 6hrs trying to resolve it and this is my last resort to post here. I’m running out of ideas and would prefer not to load windows on again as it’s a clean install already. Everything’s legit software/hardware.

The only thing I can think of is I’ve overlooked a registry clean with CCleaner or the USB port is faulty. (Have tried several other cables and USB ports, also in different order on reinstalls of Komplete Drivers etc.

I’m wondering if Uninstalling Komplete Kontakt and Drivers, and M-Audio again and then Deleting the Reg directory folders (Native Instruments/Komplete Kontrol/ and Native Instruments/Kontact Application/) shown below along with reboot and reinstall the above might set things straight?

Im hoping it’s software and someone has a solution or better still NI update with bug fixes. It’s got to be something simple as it worked fine and then bugged out.

So Thanks for your time everyone who reads and in same position and hope we’ll sort this little issue out soon.

Best Answer


  • eeZSloW
    eeZSloW Member Posts: 4 Member


    It seems the issue is with BOMEMidi driver.

    I uninstalled all software/drivers again and did a regedit to clear removed traces of software, then cleaned any listing with Komplete Kontrol DAW 1 in strings.

    I know I’ve messed up the hierarchy a little so in hindsight I’d recommend first trying to reinstall the BOMEMidi DAW 1 driver first, and if that fails then removing your Komplete Drivers, Kontact software etc , Reboot, then try agin reinstalling everything again and if still not work install the BOMEMidi driver.

    Info that helped me with trying this is linked here; https://www.native-instruments.com/forum/threads/s61-mk2-freezing-and-not-booting.323716/page-2



    Driver used: https://www.bome.com/bome/downloads/BMIDI_Driver_2.1.0.44.exe

    Everything ‘seems’ to be back to normal functioning on the controller itself so we’ll see for how long, But a better looking into this from NI Team might be priority . I do hope this can be of help to others so best of luck everyone.

    Thank you to user : MyStudioOne


  • eeZSloW
    eeZSloW Member Posts: 4 Member

    Problem arose again.

    The initial freeze boot up screen on Komplete S49. No lights, Only screens on.

    Straight away I thought to installed Bome driver again and reboot. No fix.

    Checked Task Manager and no NIAgent process listed.

    Checked Windows Services and NIAgent was in Automatic mode but not started.

    Started the service and Komplete S49 back to life.

    Very frustrating that with a brand new pc system/softwares and hardware this is turning into troubleshooting sessions rather than being productive.

    Could NI team please look into why this is happening and try rectify it with a bug fix/update. It certainly would help a lot of us. I think we all would prefer using the keyboard as is without dropouts over any new ‘features’ first. I feel this should be ironed out first before anything else. It’s not a pleasurable experience when this happens, but yes the keyboard and system is nice to use & explore👍🏻

    (Windows 11, Cubase 12 Pro, Komplete S49 MK2, M-Audio AIR 192/14).

    Thank you everyone. Any ideas/things worth mentioning/asking are more than welcomed.


  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,525 admin
    Answer ✓

    The OP reached out to support and resolved the issue by:

    1.Download the BOME MIDI SDK and reinstall Bome Driver:


    2.Then repair/reinstall Windows .NET framework :


    After that, choose the MIDI port "Komplete Kontrol DAW" in settings to set it up.  

  • keefycal
    keefycal Member Posts: 22 Member

    Hi eezeSloW

    I have just come across your missing DAW issue comments, and am wondering if it was ever solved long term. I have been struggling with this for many weeks (although it did work initially) and it is driving me insane - partly because I feel so alone! Am I really the only one suffering this massive inconvenience?

    I often suspect that something goes amiss happens when we update Windows - we would probably never know.



  • eeZSloW
    eeZSloW Member Posts: 4 Member


    If you have not done the above yet, Then open Windows Services and see if you’re NIAgents are running. (Anything listed for NI just make sure they are running and not stopped).

    If they are started/running, Then do as above with Bome Driver and NET Framework.

    I’m on Windows 11 and keep it up to date. I don’t have this issue with NI anymore but Cubase glitches sometimes from background processes which it didn’t do on newly installed OS and no updates.(Will investigate in time).

    This should get you up and running, If not please post back.


  • keefycal
    keefycal Member Posts: 22 Member

    Hi eeZSlow

    Many thanks for your response. Sorry. I have only just seen it!

    Regretfully, I am still having issues with the DAW not showing, and I have tried everything you suggested. Sometimes the NI Host.. (in 'Services' stuff appears 'Disabled' and I have to turn it on, and I have renstalled the Bome Virtual MIDI driver (and KK) numerous times. NI are on the case, but nothing seems to make a difference. I read somewhere that using a powered USB hub solved the issue - but not for me! The NET Framework thing did not produce a result either.

    Interestingly, about a week ago I had about 3-4 days of everything working (I cloned my 'C' drive at that point just in case) - then it went back to it's old habits.

    Presumably, moving to Windows 11 involved a complete reinstall of all programs etc. I'm not sure I could face that.

    If anyone else is suffering from the loss of the DAW option, and has resolved it, you would be by new best friend.

    Thanks again


  • Sp3ctrum
    Sp3ctrum Member Posts: 3 Member

    I know this post is fairly old but thought I would post a quick reply anyways. I ran into a similar issue and noticed that my antivirus suite kept trying to put the native instruments services to sleep. If you have anything like that (in my case AVG), you might want to check and see if that is the case. Especially if it works for a bit and then stops again.

  • Aravind N
    Aravind N Member Posts: 2 Member

    Another user with the same issue. Komplete Kontrol DAW-1 goes missing. Tried all the steps mentioned here. Different USB ports, cables, gold plated HQ cables, disabled Windows Defender etc. All that I can think of.

    Only time it works when uninstalling and reinstalling Mk2 driver and Komplete control. Once computer is restarted, it goes. Komplete Kontrol S2 MK2 is just 1 day old and I'm facing this issue.

  • Aravind N
    Aravind N Member Posts: 2 Member

    I think I found the issue. For Komplete Control to work in the DAW there are two window services which must be running always. Navigate to Control Panel -> Windows Services -> All Services (Control Panel\All Control Panel Items\Windows Tools)

    Look for NI Agents and restart the second one. Not sure why this isn't running by default. Says Automatic but when restarted everything gets refreshed and you are back to connection with your DAW.

    All Bome uninstall and reinstall steps are just waste of time. Just restart the services and you are good to go. This is a software bug. Native Instruments should automatically run the services when application is launched. I created a shortcut for this.

    Restart the services provided in the screenshot below:

  • Noisy
    Noisy Member Posts: 2 Newcomer

    To elaborate on the post above me, the (self) fix seems to be changing the services to “delayed start” under their options under services. Something seems to keep them from interfacing correctly automatically on startup, but if you choose delayed startup, it’ll take a few minutes to start, but seems to solve the issue. Should really be addressed on a software level though…

Back To Top