Busy season in progress... Please note that due to a high volume of requests, the response time from our support is currently longer than usual. Chat is temporarily not available. We thank you for your understanding.

Brand new Maschine+ Crashing on Startup plz help!

RKX
RKX Member Posts: 1 Noise
edited June 29 in Maschine

Hey guys I just got a brand new Maschine+ and after I entered my WIFI in the initial power up it shut off itself and the Power button is no longer lit.

I tried unplugging and replugging the power cable in and the device would automatically power on and the screen would say "Maschine+ is starting" but then a few seconds(2-4s) later it would shutdown completely. The Power button doesn't do anything and I'm left to only try replugging the cable in again and the same thing would happen.

I also tried a USB-b cable and it automatically powers on and the screen would say "Production and Performance System" for a few seconds and again shutdown completely.

Normally I'd return it and get a new one however I bought the 25th version and they seem to be out of stock so I'd like to get this one going if at all possible. Thank you for any and all help!🙏


Best Answer

  • Flexi
    Flexi Member Posts: 223 Saw
    Answer ✓

    Contact support, they will have replacement anniversary ones for replacements if needed, they can't sell things and not hold replacements for customers.

Answers

  • Flexi
    Flexi Member Posts: 223 Saw
    Answer ✓

    Contact support, they will have replacement anniversary ones for replacements if needed, they can't sell things and not hold replacements for customers.

Back To Top