After GarageBand update, Transport Controls on A-49 have stopped working - can I fix this?!

MattOakley
MattOakley Member Posts: 2 Noise
edited January 24 in Komplete Kontrol

Hi,

I’m running a KK A-49 on my MacBook Pro (Intel) and use GarageBand. After updating GB recently to version 10.4.5, I have lost all Transport Controls on the A-49 (play, record Etc.)

Previously, whenever I booted up GB it would ask if I wanted to connect to Komplete Kontrol and it has also stopped asking this. Everything else works okay.


I’m using Monterey.

Any help in fixing this issue much appreciated!

regards, Matt

Best Answers

  • darecordbreakaz
    darecordbreakaz Member Posts: 6 Sine
    Answer ✓

    Apple changed the handling of controller access in Logic X also. Roll back to a previous version of your Daw.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod
    Answer ✓

    Hello everyone, this is a known issue, it will be fixed in the next version of Komplete Kontrol. It is already available in the current Beta version. If you wish to join the Beta testing, simply like this post and I will give your emails to the Komplete Kontrol team and they will send you an invite.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod
    Answer ✓

    Hello everyone,

    Some news about the host integration for GarageBand. This issue seems to affect only Intel users, this is what the Komplete Kontrol team found out:

    We now believe that Apple has deprecated support for the remote control plugin format that we use to control GarageBand from the hardware, and instead now rely on the MIDI Device Script format. Fortunately, this is the same as the scripts we developed for integrating with Logic on silicon Macs, but unfortunately it’s really tricky to automate installation of the correct script. As such, with the current installation process, the user will need to follow these steps:

    In order to use later versions of GarageBand on an intel Mac with KOMPLETE KONTROL or MASCHINE HW:

    1 - In /Library/Application Support/MIDI Device Plugins, remove the following files:

    - KOMPLETE KONTROL A-Series.bundle

    - KOMPLETE KONTROL S-Series.bundle

    - MASCHINE MK3.bundle


    2 - In /Library/Audio, create the following folder if it doesn’t exist: MIDI Device Scripts

    and inside that folder, create a folder called Native Instruments

    This should make a path /Library/Audio/MIDI Device Scripts/Native Instruments

    Download the attached zip file and copy the entire contents to this folder.


    3 - Your hardware should now be recognised by GarageBand

    Note: this is for Intel Mac users only; on Silicon Macs these scripts will already exist.

Answers

  • Wyley
    Wyley CanadaMember Posts: 236 Saw

    I use the novation slmk2 with GarageBand and was not able to get transport controls working either. Actually before I saw your post I never though it could. I don't think this is a NI issue.

  • MattOakley
    MattOakley Member Posts: 2 Noise

    I guess the problem is the GB itself then. Has anyone managed to overcome this?

  • darecordbreakaz
    darecordbreakaz Member Posts: 6 Sine
    Answer ✓

    Apple changed the handling of controller access in Logic X also. Roll back to a previous version of your Daw.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod
    Answer ✓

    Hello everyone, this is a known issue, it will be fixed in the next version of Komplete Kontrol. It is already available in the current Beta version. If you wish to join the Beta testing, simply like this post and I will give your emails to the Komplete Kontrol team and they will send you an invite.

  • RoHo
    RoHo Eijsden The NetherlandsMember Posts: 6 Sine

    Hi Jeremy, can you tell us a date when we will be able to use garageband on Mac Monterey again? Do I really have to buy Cubase to get all my NI gear (S88 +Maschine Mikro + Komplete ultimate 13) full working again? When will the next version of Komplete Control leave the status of Beta version? Will buying Cubase solve my problem?

    Thanks for answering! 👍️

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod
    Answer ✓

    Hello everyone,

    Some news about the host integration for GarageBand. This issue seems to affect only Intel users, this is what the Komplete Kontrol team found out:

    We now believe that Apple has deprecated support for the remote control plugin format that we use to control GarageBand from the hardware, and instead now rely on the MIDI Device Script format. Fortunately, this is the same as the scripts we developed for integrating with Logic on silicon Macs, but unfortunately it’s really tricky to automate installation of the correct script. As such, with the current installation process, the user will need to follow these steps:

    In order to use later versions of GarageBand on an intel Mac with KOMPLETE KONTROL or MASCHINE HW:

    1 - In /Library/Application Support/MIDI Device Plugins, remove the following files:

    - KOMPLETE KONTROL A-Series.bundle

    - KOMPLETE KONTROL S-Series.bundle

    - MASCHINE MK3.bundle


    2 - In /Library/Audio, create the following folder if it doesn’t exist: MIDI Device Scripts

    and inside that folder, create a folder called Native Instruments

    This should make a path /Library/Audio/MIDI Device Scripts/Native Instruments

    Download the attached zip file and copy the entire contents to this folder.


    3 - Your hardware should now be recognised by GarageBand

    Note: this is for Intel Mac users only; on Silicon Macs these scripts will already exist.

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod

    @RoHo I don't have a date for the next Komplete Kontrol update but we made progress on the GarageBand integration issue, I've posted the fix in this thread. Let me know if that worked out for you.

  • RoHo
    RoHo Eijsden The NetherlandsMember Posts: 6 Sine

    Thank you Jeremy!

    The S88 (Komplete/Gb combi) seems to work now. The Maschine Mikro in combination with the S88 and GB doesn’t. When adding a Maschine track in garageband I can only record on the S88 not on the MM. The MM gives the correct sounds but doesn’t record. So, as it seems now, the S88 start to operate properly but the MM (in combination with te S88?) does not? Will all my problems be gone if I buy cubase or do you have another solution to get the S88 and the MM working together in GarageBand? Thanks for helping me out 👍️

  • RoHo
    RoHo Eijsden The NetherlandsMember Posts: 6 Sine

    In fact the Maschine Mikro (MM) in combination with Garageband (GB) seems to be not usable at all. After making a new project and VST track with Maschine the sounds can be pushed by using the pads. The other buttons are not accessible. By using the S88 I can start a recording and then a few leds on the MM are burning. Using the MM only with GarageBand also gives no working situation. MM doesn’t seem te communicate with GB. My conclusion: the combination GB and MM doesn’t work and the combination GB MM/S88 is even worse...

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod
    edited February 23

    Hey @RoHo the fix I mentioned only concerns transport / host control of Komplete Kontrol keyboards and Maschine MK3 in the latest versions of GarageBand. I suspect it is something different with your Maschine Mikro MK2, if that's ok I will get in touch by email, it'll be easier to see what's going on and what's wrong.

  • RoHo
    RoHo Eijsden The NetherlandsMember Posts: 6 Sine

    Super, thnx! I own a S88 MK2 and a Maschine Mikro MK3 😉

  • RoHo
    RoHo Eijsden The NetherlandsMember Posts: 6 Sine
    edited February 27

    Hi Jeremy,

    Thanks for helping me out, again!

    I learned a lot from your answer and was able to do what I wanted, use my Maschine Mikro 3 as a midi pad for drums.

    What I did:

    = Start Garageband

    = create new track

    = choose USB-midi keyboard

    = Load Machine 2 plug-in (Stereo)

    = Load drumkit

    = Go to group 

    = go Midi

    = Go to input

    = Set key-mode to manual

    = on Maschine micro press 

    = SHIFT and double circle (upper left)

    = Then on MM press group and PAD 15

    = On Maschine plug-in click the MM3 or S88 icon

    💪

  • Jeremy_NI
    Jeremy_NI BerlinCustomer Care Posts: 674 mod

    Hey @RoHo Thnaks for sharing the solution 🙌

  • Berth
    Berth Member Posts: 8 Sine

    @Jeremy: I got the GB-Transport issue with Apple silicon as well. Since I changed to M1 Garageband is quite shaky when I use some NI plugins.

    Well, I might just be patient waiting for an Komplete Kontrol update or switch finally to Logic ;)


    Berth

  • RoHo
    RoHo Eijsden The NetherlandsMember Posts: 6 Sine

    Hey @Berth I made the switch to Logic and it made my live a lot easier. I don’t own an M1 but as far as I can tell Logic processes Native Instruments plug-ins far better. I am still studying the ins and outs but for now it’s a big improvement😉 Wish you good luck with the M1 and please tell us what you find out 👍🏾

Back To Top