Traktor 3.5.3 - audible low frequency song distortion

La Salle
La Salle Member Posts: 2 Noise

Hi there - I noticed something quite disturbing in Traktor: when a playing song is Sync enabled, and Ableton Link function is running, you will hear clearly audible distortions on the low frequencies, especially on low bass kicks.

I tried on several computers, any CPU, any Windows version will do. The song volume is not relevant nor is the signal strength (did not try on Mac but I think it could be the same):

How to reproduce on a standalone Traktor 3.5.3 (latest version as per today):

  • Load and play a song having lots and repetitive low frequency kicks (10-50 Hz).
  • Enable Ableton Link and, enable Sync on that loaded and playing song (you don't need to have any other device connected to it).
  • Listen to the audible low frequency artifacts. Enable and disable Sync to hear the distortion go on and off. Enable/Disable Ableton Link, you will hear the same problem. It sounds like the signal is saturated, but in reality it is not.

I would be interested in knowing if anybody else has experienced the same problem. Especially from NI, I would like to hear if this is a known bug, since this is I think quite important to address and if left like it is now, it will make the Ableton Link function non-usable.

Thanks.

Tagged:

Answers

  • Stevan
    Stevan MIDIMember Posts: 237 Saw

    Hey there, I'm glad to hear that I'm not alone with that bug. It was introduced with addition of BeatportLink and Beatsource Link integration.

    I reported it but nobody could duplicate the problem. Thank you.

  • Stevan
    Stevan MIDIMember Posts: 237 Saw

    No such issue on mac by the way. (Intel or M1)

  • Ryan_NI
    Ryan_NI BerlinCustomer Care Posts: 157 mod

    hey! I, myself, haven't heard of this issue just yet. let me try to repro on my end as well as speak with my colleagues and see if we have any more information for you.

  • La Salle
    La Salle Member Posts: 2 Noise
    edited May 31

    Thank you Ryan - let me know if I can help in any way, you can reach out to me directly if you need help to reproduce this. It is important to have Ableton Link AND the song Sync enabled to hear it. It took me a long time to figure this out.

    I'm watching in real-time the progress on this. I'm using Ableton Link a lot and Traktor is the central component on my equipment, so I take this quite seriously.

    In order to really hear this the first time, it is easier to have a song running only with low kicks (and put this in a 8 beats loop) with no follow up sound after the quick (although the artifacts get added to the overall signal).

    The artifacts sound is like you would squash an empty cardboard box.

    (I tried to upload a small example with and without the noise, but it wont let me)

  • Kaiwan_NI
    Kaiwan_NI BerlinAdministrator Posts: 1,119 admin

    Hi @Ryan_NI do you have any luck reproducing the bug?

Back To Top