Traktor 3.5.3 - audible low frequency song distortion

La Salle
La Salle Member Posts: 2 Member

Hi there - I noticed something quite disturbing in Traktor: when a playing song is Sync enabled, and Ableton Link function is running, you will hear clearly audible distortions on the low frequencies, especially on low bass kicks.

I tried on several computers, any CPU, any Windows version will do. The song volume is not relevant nor is the signal strength (did not try on Mac but I think it could be the same):

How to reproduce on a standalone Traktor 3.5.3 (latest version as per today):

  • Load and play a song having lots and repetitive low frequency kicks (10-50 Hz).
  • Enable Ableton Link and, enable Sync on that loaded and playing song (you don't need to have any other device connected to it).
  • Listen to the audible low frequency artifacts. Enable and disable Sync to hear the distortion go on and off. Enable/Disable Ableton Link, you will hear the same problem. It sounds like the signal is saturated, but in reality it is not.

I would be interested in knowing if anybody else has experienced the same problem. Especially from NI, I would like to hear if this is a known bug, since this is I think quite important to address and if left like it is now, it will make the Ableton Link function non-usable.

Thanks.

Tagged:

Best Answer

  • Isotoxin
    Isotoxin Member Posts: 117 Helper
    edited May 2023 Answer ✓

    Hey!

    Because I'm using external mixing (UMC1820 + Model1), I have removed headroom from mixer settings and disabled limiter. But I don't know why Traktor shows clipping on the limiter after the disabled headroom and limiter. But this is not the case because even if I add -3dB headroom to remove these peaking the glitches are the same.

    BUT.

    The disabled keylock has been fixed the the glitches!!! Or I need to use Ableton Link as I'm using now - sync songs at the deck loading and disable SYNC afterwards and nudge the slowly shifting tracks from time to time. :)


    P.S. In the end, I have added headroom, because I did not think what effects can drastically increase clipping on the output of track.

Answers

  • Stevan
    Stevan Member Posts: 1,510 Expert

    Hey there, I'm glad to hear that I'm not alone with that bug. It was introduced with addition of BeatportLink and Beatsource Link integration.

    I reported it but nobody could duplicate the problem. Thank you.

  • Stevan
    Stevan Member Posts: 1,510 Expert

    No such issue on mac by the way. (Intel or M1)

  • Ryan_NI
    Ryan_NI Customer Care Posts: 191 mod

    hey! I, myself, haven't heard of this issue just yet. let me try to repro on my end as well as speak with my colleagues and see if we have any more information for you.

  • La Salle
    La Salle Member Posts: 2 Member
    edited May 2022

    Thank you Ryan - let me know if I can help in any way, you can reach out to me directly if you need help to reproduce this. It is important to have Ableton Link AND the song Sync enabled to hear it. It took me a long time to figure this out.

    I'm watching in real-time the progress on this. I'm using Ableton Link a lot and Traktor is the central component on my equipment, so I take this quite seriously.

    In order to really hear this the first time, it is easier to have a song running only with low kicks (and put this in a 8 beats loop) with no follow up sound after the quick (although the artifacts get added to the overall signal).

    The artifacts sound is like you would squash an empty cardboard box.

    (I tried to upload a small example with and without the noise, but it wont let me)

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,524 admin

    Hi @Ryan_NI do you have any luck reproducing the bug?

  • Isotoxin
    Isotoxin Member Posts: 117 Helper

    I can confirm this problem still persist in version 3.9.

    I'm using Windows and to reproduce the problem it just enough to enable Ableton Link button and button SYNC on any playing track. Loop the beat and You will hear the glitches like in this link seconds 2-3: https://mega.nz/file/k85DyL6R#i6u8j8txZXvNnizEV2IbTEtaZiAp2040u6_D0nx8Y_s

    Here is the same loop without SYNC engaged: https://mega.nz/file/l8YGgBTQ#nkhSJ-_5lATDeIHk9017i7LYIaEkJUlhI-GiU8g3Rv0

    Here is the pictures of the same loops (i have marked the glitch part in yellow):

    https://mega.nz/file/ohxESCgJ#rvJaEeNjS96khXooaT8hPhmSeKnpVHRhrQelmiy-C0Y

  • Markovicz
    Markovicz Customer Care Posts: 381 mod

    Hi there,

    We have tried to reproduce this with

    • Sinewaves
    • Impulses
    • Regular Kickdrums

    And we could observe no difference in the recording between sync, no sync, master or LINK.

    What we did then is to try with the "non problematic" recording of the user and ... nothing either. The only thing that we see left which would also explain why we didn't receive so many report for something super common is that they use a specific file format.

    It would be great If one of you could upload an original file that you have observed this distortion with.

  • Isotoxin
    Isotoxin Member Posts: 117 Helper

    I think the problem only relevant for Windows users (I'm the one). I will try to check WASAPI driver instead of ASIO and update my comment. But at least there is no difference what audio interface I'm using. Integrated Realtek or external UMC1820.

    To hear the distortions there is no difference what audio format or song file I'm using. Mp3, flac, wav - everything is the same. It's enough to just enable Ableton Link and engage the SYNC button on the deck. And to hear the glitches clearly I'd recommend to use HPF on the deck and use any song without to many middle and high frequency Instruments. And use headphones, not the speakers.

    My examples in Mega links give the clear view how glitches sounds like.

  • Isotoxin
    Isotoxin Member Posts: 117 Helper
    edited May 2023

    As I have promised, here is the example of the sound glitches with the Traktor Pro 3.8.

    The song as You can see in the video is a "Dark Angel" by "21 ROOM". And it is just a looped 1 beat of the second bar in the song on the DECK A. I have used this song just because not every looped (glitching is not only loops but on playing straightforward songs too with SYNC + LINK engaged) song will have this glitch as expressive as this one. I think it depends on the frequencies in the playing loop to be noticeable clear as in this one song.

    In the process of recording I have adjusted the filters of my mixer few times (tried to get these glitches more noticeable), so the sound will change in volume/filtering a little bit over time, but this is not the point. The point is, You need to listen to this video with a headphones, and with a higher volume to catch these subtle glitches as I named it - "pillow scratches". The best part is last 15 seconds there you can hear the soft scratches.

    You can hear in the video what the beat is looping perfectly fine up until 13 second of the video when I have pressed SYNC button (keep in mind, the ABLETON LINK button is ACTIVE from the start). Even at the moment when I pressed the button, the sound distorted a little bit and it will keep randomly and softly glitch overtime until i disengage the SYNC button OR the ABLETON LINK button. Because the problem is not the SYNC itself. The problem is ABLETON LINK + SYNC both enabled. And only in these combination You will hear this soft scratches. BTW, there is no difference if I'm using ASIO or WASAPI driver, external, or internal mixing. Glitching is here when LINK AND SYNC BOTH buttons ar active. And there is no glitching if I'm using MIDI SYNC instead ABLETON LINK.

    My OS is Windows11 with latest updates, but AFAIK the problem persisted in the 10 version too.

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,459 Expert
    edited May 2023

    In your video i can see two things that may have something to do with it:

    1. Keylock is on. With the non-constant AbletonLink tempo this may be the cause. Have you tried this without Keylock?
    2. Your audio is peaking and the limiter is off. Can you still hear it if you trim down the volume a bit?
  • Isotoxin
    Isotoxin Member Posts: 117 Helper
    edited May 2023 Answer ✓

    Hey!

    Because I'm using external mixing (UMC1820 + Model1), I have removed headroom from mixer settings and disabled limiter. But I don't know why Traktor shows clipping on the limiter after the disabled headroom and limiter. But this is not the case because even if I add -3dB headroom to remove these peaking the glitches are the same.

    BUT.

    The disabled keylock has been fixed the the glitches!!! Or I need to use Ableton Link as I'm using now - sync songs at the deck loading and disable SYNC afterwards and nudge the slowly shifting tracks from time to time. :)


    P.S. In the end, I have added headroom, because I did not think what effects can drastically increase clipping on the output of track.

  • Sûlherokhh
    Sûlherokhh Member Posts: 1,459 Expert

    It is known that Keylock has issues, which is why i don't use it on main tracks. Good you were able to pinpoint the problem.

  • amercier
    amercier Member Posts: 3 Newcomer

    Hi !

    I'm having the exact same issue. The glitch on the bass appears when Link + Sync + Keylock are activated simultaneously. I just updated Traktor from 3.8 to 3.11, but the bug persists, with multiple audio interface, even if Ableton is not open (just activating Link by itself with keylock makes the glitch appear). I'm on Windows 10 (is this problem fixed in Windows 11?).

    This problem is very anoying, as Keylock is very important for me, so I have to disable Link and sync with Ableton using Midi (wich is way less stable than Link...).

    Is there any update on this topic ? Or other people still experiencing this issue ?

Back To Top