Traktor Kontrol S4 Mk3 - TT mode one turntable controls the other.

mixmastawood
mixmastawood Los AngelesMember Posts: 9 Sine

All of the sudden, Traktor Control S4 MK3 plays on either deck fine, but once I put Deck A or B in TT mode, the opposite turntable (while trying to cue the song) takes control of the other deck (only in reverse). This makes it impossible to mix. It actually controls the other jog wheel hands free.

Restored Defaults, Re-installed Traktor Pro 3.

Help please, losing money here.

Tagged:

Best Answer

«1

Answers

  • mixmastawood
    mixmastawood Los AngelesMember Posts: 9 Sine

    After doing more experimenting, I tried it on a 2011 MacBook Pro with a fresh install of Traktor Pro 3 and it worked fine. So it’s definitely in the software because it used to work just fine on my M1 Mac mini. I’ve completely uninstalled software all extensions subfolders and still no luck.

  • zephry
    zephry SeattleMember Posts: 93 Tri

    When a deck is master and another is synced it will fluctuate the bpm.

  • mixmastawood
    mixmastawood Los AngelesMember Posts: 9 Sine

    I’m aware of this, but this is a different issue. The actual platter is spinning when I spin the other platter. Whether or not the master or sync button is pushed. Has nothing to do with beat per minute it is actually physically spinning as if I flicked the wheel in reverse. If I actually flick the opposite platter, both of them start fighting each other back-and-forth. I could walk away from the system and both of them are activating each other in an endless loop I have to physically stop both tracks and put my hands on the platters to stop them.

  • zephry
    zephry SeattleMember Posts: 93 Tri

    Wow? Hope that doesn't happen to mine. Thanks for the more detailed explanation!

    Double check that all mappings are routed correctly? Inputs not set to "all"?

    No idea what else, never heard of anything like this happening.

  • mixmastawood
    mixmastawood Los AngelesMember Posts: 9 Sine

    The NI Controller Editor Software doesn't support the S4 MK3 ( my Maschine, Jam, and S61 all show up) it's not a selectable option for offline devices either. I even made a new user on my Mac and still no luck. I imported all root files and folders from time machine dated back when it all worked. hardware works fine on MacBook Pro 2011. I've also unplugged ALL usb devices. Nada.

  • zephry
    zephry SeattleMember Posts: 93 Tri

    Correct. Forgot about that. Definitely get a hold of support and possibly a defective unit.

    The S4mk3 isn't that old but still I am already preparing for the possibility of mine failing and replacing or even going to Denon (sadly) if NI doesn't come out with something new in the next year. If mine holds up though, I will definitely wait longer. I still use the S8 I bought as well (still going strong).

    But yeah get a hold of support on this. Please post the details and how it all goes for you, we are all interested for sure.

  • Sir_Kato
    Sir_Kato NorwayMember Posts: 6 Sine

    Unfortunately I had the same issue appear for me today. I will see if I can remedy the situation myself but it's likely we're in the same boat. 😢

  • Sir_Kato
    Sir_Kato NorwayMember Posts: 6 Sine

    Quick sidenote, this happened after updating Traktor Pro 3 yesterday.

  • Sûlherokhh
    Sûlherokhh GermanyMember Posts: 211 Saw

    In which Traktor versions do these problems appear?

  • mixmastawood
    mixmastawood Los AngelesMember Posts: 9 Sine

    3.5.3 Traktor Pro 3. The devs just sent me a copy of 3.5.2 installing now.

  • mixmastawood
    mixmastawood Los AngelesMember Posts: 9 Sine

    did not work.

  • Sir_Kato
    Sir_Kato NorwayMember Posts: 6 Sine

    I was recommended to remove the settings file from documents -> NI, also did not work.

    I'm, also on 3.5.3.


    Here is some additional info after I had a little more time to fiddle around with it:

    "Hi, unfortunately this has not resolved the issue.

    This seems to occur when both decks are playing. HAving the sync buttons on or off does not seem to make a difference.

    I have tried both platter speed settings.

    The problem still occurs when one jogwheel is in Jog mode with the other in TT mode, or with both in TT. Backspinning the deck on Jog mode will affect the deck on TT mode as well.

    The master button flashes erratically when the interference occurs."

  • mixmastawood
    mixmastawood Los AngelesMember Posts: 9 Sine

    I also noticed that you don’t even need to have any songs loaded. Not to mention that in your song list the key of the song icon flashes on some some songs

  • Sir_Kato
    Sir_Kato NorwayMember Posts: 6 Sine

    Hmm imma test this out see if it's the same here, I was more focused on the hardware.


    ****Tried posting this yesterday, didn't seem to go through******

    Essentially:

    Jog or TT deck will affect a TT deck (No matter A, B, C, or D)

    TT or Jog does not affect a Jog deck.

    There is something wrong specifically with the turntable functionality. I'm unsure of the architecture of this new jogwheel mode but it seems that somehow the signals from any deck being backspun are being fed to the motor of any deck in TT mode, regardless of the mode of the deck the user is manipulating is in.

    It's also worth noting that if I backspin very slowly, it seems to take a little longer for the interference to begin. A nice quick "pull up" though triggers it much more quickly.

    Damage is an unlikely cause as I bought mine brand spanking new (1.5 months ago), unboxed it at home and it's been sitting in the same place ever since. I never eat or drink around my gear, and I've only got about max 14 hours on it. I also like to finesse my equipment, I have never slapped my babies around even in the excitement of a really dope track. This ***** makes me wanna cry cus I was super excited about the turntable mode :(

  • Sir_Kato
    Sir_Kato NorwayMember Posts: 6 Sine
Back To Top