Komplete 14 Select Compatibility

Options
bmurphy33
bmurphy33 Member Posts: 2 Newcomer
edited April 2 in Komplete General

Hello.. I just downloaded Komplete 14 Select and it doesn't seem to work with my OS. High Sierra 10.13.6. Any advice or way I can use a previous version?

Best Answer

  • mykejb
    mykejb Moderator Posts: 1,385 mod
    Answer ✓
    Options

    Unfortunately the requirements for K14 Select start at MacOS 11 so it won't work on High Sierra. The only option I'm aware of is to upgrade your OS which will depend on your hardware.

Answers

  • mykejb
    mykejb Moderator Posts: 1,385 mod
    Answer ✓
    Options

    Unfortunately the requirements for K14 Select start at MacOS 11 so it won't work on High Sierra. The only option I'm aware of is to upgrade your OS which will depend on your hardware.

  • bmurphy33
    bmurphy33 Member Posts: 2 Newcomer
    Options

    Thats what I figured. Thank you very much. I'm looking to upgrade to Big Sur now since my computer is a bit dated. (2015).

Back To Top