Maschine+ MIDI mode not working

Options
Percivale
Percivale Member Posts: 211 Advisor
edited March 31 in Maschine

MIDI keyboard into Maschine+ I have experience making some songs in the same way before. This happened after shutting down the device, i.e. upon reboot the MIDI would not function. I had tried [Settings - MIDI], [Channel-MIDI] using past settings and messing about with both illogical and logical configurations. Nothing seems to work. I tried BT MIDI and also wired MIDI (even changing a MIDI cable just in case). In desperation, I booted into controller mode and Maschine 2 software and after messing again (as above) suddenly the MIDI worked - it was under [Settings - MIDI], setting it to focus.

I reboot into standalone mode and nothing would work again. It is not the first/last time I am using MIDI on a Maschine+. Updated firmware to the latest 2.17.5. Any suggestions?

Answers

  • Percivale
    Percivale Member Posts: 211 Advisor
    edited March 31
    Options

    So I tried a synth device MIDI In/Out to the MIDI keyboard mentioned above. Goes bidirectional okay. That means it wasn't the MIDI keyboard or the cables, which only leaves the hardware or software settings on Maschine+

  • ozon
    ozon Member Posts: 1,470 Expert
    Options

    You mentioned changing MIDI settings, but did you set the Group/Sound to receive and react to MIDI on the channel the keyboard is sending?

  • Percivale
    Percivale Member Posts: 211 Advisor
    edited March 31
    Options

    Thanks. Yep. Tried already. Now I can confirm MIDI works with MIDI keyboard on controller mode but not standalone.

  • ozon
    ozon Member Posts: 1,470 Expert
    Options

    @Percivale I just tested this:

    • Put a Monark instance on Group A Sound 1
    • Put a Drum kit on Group B
    • Connect Virus TI keyboard via USB
    • Settings -> MIDI -> MIDI Input -> Default -> NONE
    • Settings -> MIDI -> Input Devices -> Virus TI -> ON
    • Select Group A / Sound 1
    • Channel MIDI -> Sound -> Input -> MIDI -> Source: Virus TI

    Now I can play Sound 1 via the Virus TI keyboard and to a drum pattern running on Group B.

    What am I missing?

    Maschine+

    • Sytem Version: 1.5.1.0
    • Maschine Version: 2.17.5
    • Firmware: 0.1.9


  • Percivale
    Percivale Member Posts: 211 Advisor
    Options
  • ozon
    ozon Member Posts: 1,470 Expert
    Options

    @Percivale ok, with old fashioned DIN MIDI cable:

    • Put a Monark instance on Group A Sound 1
    • Put a Drum kit on Group B
    • Connect Virus TI keyboard via MIDI out to Maschine Plus MIDI in
    • Settings -> MIDI -> MIDI Input -> Default -> NONE
    • Settings -> MIDI -> Input Devices -> Maschine Plus/Maschine Plus MIDI 1 -> ON
    • Select Group A / Sound 1
    • Channel MIDI -> Sound -> Input -> MIDI -> Source: Maschine Plus/Maschine Plus MIDI 1

    Now I can play Sound 1 via the Virus TI keyboard and to a drum pattern running on Group B.

    Same as with USB.

  • djenco
    djenco Member Posts: 3 Newcomer
    Options

    I have the same problem

Back To Top