Kontrol S2 Mk3 Browser button not working

Flaekingr
Flaekingr Member Posts: 4 Newcomer

Hey folks. I just picked up a second hand s2 mk3 and the browser button on Deck B won't select a track. It scrolls left and right just fine, it makes a good click just like the browser button on Deck A (which works as it should), it just won't actually select the highlighted track. What can I do? Is this a setting that needs to be changed somewhere? Is the button just dodgy? If so, is it replaceable/repareable? Can we get into these things and check connections. I just got this controller and want to enjoy it.

Cheers.

Tagged:

Answers

  • lord-carlos
    lord-carlos Member Posts: 2,302 Expert

    When you press it down, does the "midi signal received" symbol in traktor light up?


  • Flaekingr
    Flaekingr Member Posts: 4 Newcomer

    No, it doesn't

  • lord-carlos
    lord-carlos Member Posts: 2,302 Expert

    But I assume it lights up when you press other buttons?

    I would assume it's a hardware defect.

  • Flaekingr
    Flaekingr Member Posts: 4 Newcomer

    Yes, the other buttons work as they should and the midi light lights up for them. Assuming hardware defect, what can I do about it?

  • lord-carlos
    lord-carlos Member Posts: 2,302 Expert

    I would open it up and poke around with a multimeter :D But not something I would recommend.

    Best bet is to contact support.

    You have to answer some questions and then it should let you open a surppport ticket: https://support.native-instruments.com/hc/en-us/sections/15449821909021

  • Flaekingr
    Flaekingr Member Posts: 4 Newcomer

    Yeah cheers, I've been in touch👍️

Back To Top