Kontakt freezes DAW when loading some libraries

Nikolay
Nikolay Member Posts: 5 Newcomer
edited April 2022 in Kontakt

Hello, I have a big problem (actually there are 2 problems which can be correlated). When loading, for example, Session Guitarist - Electric Sunburst Deluxe, the whole DAW freezes for about 2 minutes. Then everything is ok until the next time the library is loaded. I made batch re-save, enabled samples loading in background and tried to switch multicore processing to off. Nothing works, it still hangs the DAW for a long time. What is the reason for that? Most other libraries load without that freezing.

Another problem: when using Studio One, while loading the project with kontakt plugins, the loading screen also freezes on "Loading Control Surface". And it also takes on the average 2 minutes per plugin instance. So when I have 10 kontakt plugins, it takes 20! minutes to just load the project. And this problem probably occurs with all libraries, not just Electric Sunburst.

What's the problem? How to solve it? It really doesn't let me work.

Answers

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    Where is the SG library installed (system drive, ext. drive)? what kind of drives (Normal HD or SSD)? The SG libraries are quite large and if loading from a regular HD can take some time. You can speed up the process by #1 make sure to batch re-save the Library with the latest version. #2 make sure to exclude libraries from any real-time virus scanning (Windows Defender). #3 once loaded and you have let the track play, do a sample purge. Any unused samples will not be loaded. (There are drawbacks to purging, so read the Kontakt manual for more information) That will help speed things up, but if you do not have a SSD drive, I would consider getting one…they make all the difference in the world!

  • Nikolay
    Nikolay Member Posts: 5 Newcomer

    Thanks for the answer

    #1 I already did batch re-save. It made samples loading faster but didn't solve the freeze issue AFTER the samples are loaded.

    #2 Yes, forgot to say that I excluded library folders from antivirus.

    #3 The problem is not while paying back but while loading the library so it doesn't help.

    I have libraries on hdd, but I think this should not be the argument. There are features in Kontakt which should speed up the process even with slow drives. As I see at the moment, these features are just not working correctly.


    I did more research on the one of the problems which is long project loading time in Studio One. Here are the weird things I found out:

    I have two projects, a small one for testing and a big one I'm currently working on, but both of them have only 3 Kontakt instances with same instruments. The small project loads fast as expected and after the project is loaded, Kontakt begins to load samples in background. But this is not the case for the big project. I used process monitor to see which actions Kontakt is performing. When the loading screen of Studio One is stuck on "Loading control surface", Kontakt loads all the samples for some random instruments. After all samples for these instruments are loaded, Studio One opens the project. Then I can see and confirm that some of the instruments are fully loaded, whereas the remaining instruments load in background as expected.

    For me it looks like Kontakt does not send some sort of a signal that it's ready to Studio One. I hope this is not true and there is a very non-obvious option I need to check.

    Of course, I have "load samples in background" selected, everything is batch re-saved

  • EvilDragon
    EvilDragon Moderator Posts: 1,021 mod

    Yeah I'm pretty sure this one is about adding exclusions to Windows Defender (although OP didn't say if they are on Windows or not).

  • Nikolay
    Nikolay Member Posts: 5 Newcomer

    I fully disabled the antivirus. Nothing changed. The strange problem I researched in the previous comment looks like it's not because of the antivirus.

  • Blindeddie
    Blindeddie Member Posts: 1,559 Expert

    "Kontakt loads all the samples for some random instruments"

    What exactly does that mean? Are those instruments used in the project or are you saying Kontakt is loading samples that are not associated with the project?

  • Nikolay
    Nikolay Member Posts: 5 Newcomer

    I have 3 kontakt instances with instruments. Let's name them "piano", "guitar" and "drums". Under random instruments I mean, for example "piano" and "drums"

  • Nikolay
    Nikolay Member Posts: 5 Newcomer
    edited April 2022

    Ok seems like I found a solution to one of the problems. In studio one under song settings I had sample rate 48000 hz. When I switched to 44000, the project loaded very fast. Very strange.

    But the first problem with too long freezing times when loading some instruments or switching presets is still there.

Back To Top