UVI & NKS - issues?

Options
holonology
holonology Member Posts: 83 Helper
edited March 9 in Komplete Kontrol

Hi folks, random weekend question for you. Apologies if this has been asked before.

I missed the sale with UVI but I maintain an interest in their Synth Anthology 4. I took out a subscription to Sonic Pass by way of a pre-purchase trial, and downloaded eveything just fine including iLok, Falcon and Workstation. I believe that NKS support is a condition of NI sales, and I noticed that only the specific products in the sale are listed as NKS compatible, which is great news. I like the UVI concept of the Anthology and a single plugin for accessing all sounds a smidge more than Arturia's approach of multiple synths, as this meshes well with KK and that 8 macro concept.

Given this was a recent partnership, I was quite surprised to then get the classic "may not support Apple Silicon or VST2 to VST3 migration" message. I don't (and won't) run anything in Rosetta, because my whole machine only features Apple Silicon products as I started producing in 2022, and I don't want to revert my system to Rosetta for one plugin given 99% of stuff is M1 native now.

Is there something I need to change here (eg: point KK at the VST2 version somehow?)

Not the end of the world if this doesn't work as I have other options - but I thought it was strange this wasn't working out of the gate on a new bundle and new NKS partner.

Tagged:

Best Answer

  • holonology
    holonology Member Posts: 83 Helper
    Answer ✓
    Options

    OK, tail between legs - a restart and a re-install solved this one. I re-built the kk database as well and all is working now. I guess it's strange because so far these libs have loaded flawlessley for me from the store. Happy to have it up and running.

Answers

  • PoorFellow
    PoorFellow Moderator Posts: 3,765 mod
    edited March 9
    Options

    Most likely you will need an answer from either Jeremy_NI (who's attendance here has been slightly unpredictable lately , might be ill or something, but no matter will not be here before Monday or later) or you will have to contact N.I. support or UVI support .

    EDIT , user has reported problem solved , ping for Jeremy_NI removed !

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,058 mod
    edited March 9
    Options

    I was quite surprised to then get the classic "may not support Apple Silicon or VST2 to VST3 migration" message

    You shouldn't - certainly all their Falcon and Workstation based products migrate, as do their effects

    point KK at the VST2 version somehow

    Not if you don't want to use Rosetta. These should be working on Apple Silicon and migration should not be an issue, I don't have the entire bundle but I do have a lot of Falcon/WS products and they all work fine for me without needing Rosetta so it might be a local setup issue

  • holonology
    holonology Member Posts: 83 Helper
    edited March 9
    Options

    Thanks folks, I'll look into it a little deeper and mention it to support. If Jeremy_NI or anyone comments, perhaps it will be useful for others if they see the same issue. All installed as per a standard install, all on the latest versions of everything on a Mac MI. NA & all NI software is up to daye, and I literally just got the UVI portal so that's as fresh as a daisy. I'll do a re-start/re-install of the plugins and see if that helps.

  • holonology
    holonology Member Posts: 83 Helper
    Answer ✓
    Options

    OK, tail between legs - a restart and a re-install solved this one. I re-built the kk database as well and all is working now. I guess it's strange because so far these libs have loaded flawlessley for me from the store. Happy to have it up and running.

Back To Top