Anyone know if you can Rollback VST3 version to 2.9.x ? (I do not mean VST2 version)

Options
hammanca
hammanca Member Posts: 3 Member

Lads, Anyone know if you can Rollback VST3 version to 2.9.x ? (I do not mean VST2 version) ?

Since I moved to the version 3.x.x Komplete Kontrol no longer loads any of my Sonuscore and BBC tracks. The instruments do not load. I have logged a ticket with NI before in regard to this - added to that a project file and did a big capture of output for them too. (think it just reviewed all my plugins really).

Here's the thing, if starting a new project and loading the very same plugins and saving that - and reopening that - no problem. But my vast back catalogue of tunes do not load.

Daw: Cakewalk / Maschine / Windows 11 / i5- 16GB Gen8 / Everything super good enough - and has been for 4 years until this last Christmas when it all broke, with me buying the new komplete :(. and upgrading wish I hadn't now.

Comments

  • PoorFellow
    PoorFellow Moderator Posts: 3,765 mod
    Options

    And you already tried the Resetting the Komplete Kontrol Database ?

    There is also a reinitialize the KONTAKT Database though from what you write then that probably is not applicable here ?

    Also apps must be opened as stand-alone at least once before used in the DAW !

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,058 mod
    edited March 6
    Options

    Yes you can roll back - installers are in this thread

    https://community.native-instruments.com/discussion/17363/komplete-kontrol-s-series-mk1-keyboards-end-of-life/p1

    However if your tracks are not opening the BBC etc plugins do you know if they were using the VST2 or 3? (of the plugins not KK) . If the former try adding the VST2 path to KK first then rescanning plugins so it can load the VST2 versions

  • hammanca
    hammanca Member Posts: 3 Member
    Options

    Thanks Guys, I have been using the VST3 version all this time and yes I did also do the necessary Re-initalize of the Database too. Tried any number of different solutions; no luck! Anyways I'm fed-up and moving backwards. And once I have all my gear working and tunes completed, I will freeze tracks / or export each to audio and leave it at that.

    Struggling with this new version of Komplete! I will get back to you in due course.

    thanks!!

  • Vocalpoint
    Vocalpoint Member Posts: 1,331 Guru
    Options

    Unless you own a new Mark III Series controller - there is no point to be using KKv3 whatsoever.

    Simply stay on KK v2.9.6 and make music.

    VP

  • hammanca
    hammanca Member Posts: 3 Member
    Options

    All, re-installing that has put it all back and working - THANK YOU so much for that link. I knew with all the issues that were out there they must have relented and given a rollback - I really appreciate that. Version 2.9.6 long may it stay.

    VP, have to agree however after this experience I'm likely to move to Akai or Arturia now. My MK2 has been the best thing I ever got - until I made the error and upgraded the Komplete. I also own and use my Maschine MK3 - but rather more as a Midi Controller (easy to program) then in maschine itself. It is a great tool, and believe me as a Midi Controller few are better for programming and recalling programmed parameters for different instruments. Pity they didn't build that into their Keyboards too. Although, quite sure others link the new Arturia are making this functionally available on their new Keys.

    Again my thanks to all for your advice and help.

    Wishing good health and happy composing.

  • PoorFellow
    PoorFellow Moderator Posts: 3,765 mod
    edited March 8
    Options

    From the way that you present it I can not blame your attitude !

    There has been far too many updates that relies on updates on other stuff that relies on update of other stuff. And each of these with built in problems for some or many either by itself or giving indirect problems because of problems for some or many with what it relies on.. (for some reason I can never find the 'Face-palm' 'emoji' here if I need one)

  • Kymeia
    Kymeia NKS User Library Mod Posts: 4,058 mod
    Options

    I have been using the VST3 version all this time

    I know, you said that, but I wasn't meaning the VST3 of KK but were the plugins you were loading into KK the VST3 versions? KK3 defaults to VST3 only and you have to add the paths manually to VST2 plugins if you still want to use them so naturally if you haven't, unless they migrate to VST3, it won't find them

Back To Top