Maschine and Apple Silicon

marten10bones
marten10bones Member Posts: 7 Member

I have been using Maschine since 2015 on an iMac and it died last year. I bought a Mac Studio with an Apple M1 Ultra chip. I hadn't really had a chance to use it until recently. At first everything was fine, then it became unusable. The CPU levels were through the roof, audio was glitched and garbled, even after adjusting the buffer size. In one project I removed all VSTs and effects after bouncing to audio, and it made absolutely no difference. Then I started having more trouble; Maschine crashed several times, kernel panics, kext issues. I tried everything I could find online to fix it and nothing worked. I finally decided to just erase my hard drive and start all over. That was fun. I think I brought issues with me from my iMac, and saw where other people had problems with System Migration, Audio problems, kernel crashes, kexts seem to be an issue as well. Has anyone else been experiencing difficulties with Apple Silicon and Maschine? I've found a few cases online but generally it seems not many people are having issues. I already downloaded Maschine but haven't had a chance to test it yet. I'm begininng to think there is no fix and I'm just screwed. I almost didn't get another Mac and now I am seriously regretting it. This has been a nightmare. Any help or suggestions, thoughts.....thanks

Best Answers

  • tetsuneko
    tetsuneko Member Posts: 555 Guru
    Answer ✓

    There is a known issue with the latest Maschine software and M1 Max & Ultra chips. NI is working on solving the issue. In the meantime, users are recommended to downgrade affected systems to an earlier version of Maschine software.

  • solsta
    solsta Member Posts: 91 Helper
    Answer ✓

    Check this link out, I reported this issue some time ago and got the ball rolling, there is a link to the earlier version of maschine in there, you can click on it and download, it fixed all my issues for the moment.

    Older version is a google drive link you should be able to find in that thread, hope this helps!

Answers

  • tetsuneko
    tetsuneko Member Posts: 555 Guru
    Answer ✓

    There is a known issue with the latest Maschine software and M1 Max & Ultra chips. NI is working on solving the issue. In the meantime, users are recommended to downgrade affected systems to an earlier version of Maschine software.

  • marten10bones
    marten10bones Member Posts: 7 Member

    I appreciate your response. That clears up some things for me. Now to find an earlier version of Maschine. Thanks for the information.

  • solsta
    solsta Member Posts: 91 Helper
    Answer ✓

    Check this link out, I reported this issue some time ago and got the ball rolling, there is a link to the earlier version of maschine in there, you can click on it and download, it fixed all my issues for the moment.

    Older version is a google drive link you should be able to find in that thread, hope this helps!

  • marten10bones
    marten10bones Member Posts: 7 Member

    Yes it does! Thanks! I had put in a support ticket to NI and was thinking it may take forever to get a response, so again THANK YOU!!

  • marten10bones
    marten10bones Member Posts: 7 Member

    well i don't see the link but i'll try to search for it.

  • marten10bones
    marten10bones Member Posts: 7 Member

    I found it Maschine 2.17.4 https://drive.google.com/drive/folders/1tlbK6o1sF_616JB4drsr24c4K8CqKgrO?usp=drive_link it does seem to work better but if you check out the included screenshot its eating 158% CPU. The strange thing is that the System is at 86%. So far I'm not having audio issues but I have a project open that is nothing but bounced audio. No VSTs or effects. I think if plugins were loaded I'd be el f#$@-o'd. Thanks again. Hopefully this cures it for a moment but I think Apple means to make things even harder. I won't be updating any software or buying Apple computers anymore. This has been a real eye open-er. I don't understand why they care what people do on their computers, leave everything alone. I paid for it, I have the right to do whatever I want including delete, move, remove, modify, tamper with, destroy...anyway it doesn't change anything and from what I find online, it's kinda scary considering how much money I've put into everything. This is my third mac over the course of almost 15 years! whatever....


  • tetsuneko
    tetsuneko Member Posts: 555 Guru

    Something is up with those M1 Ultra & Max CPUs. I reckon its only a matter of time before this sort of issues get taclked though.. give it time

  • solsta
    solsta Member Posts: 91 Helper

    @marten10bones im glad it sorted your issue somewhat! I also really was struggling, its true its not yet perfect with cpu usage which is weird but at the moment im hoping that they are working on a replacement update which willl solve the issues we were having!


    @tetsuneko fingers crossed!!!

  • marten10bones
    marten10bones Member Posts: 7 Member

    @solsta (didn't realize you could tag on here) thanks I appreciate it. It's hard to find help online, especially when there are so many results that contradict each other. I received a response from NI yesterday with a link to 2.17.4, and they asked which version I wanted to roll back to. I responded that version 2.17.4 was fine and I included that screen shot of the CPU going nuts. Along with a complaint about how much money I've spent at NI and Apple over the last 13 years. They probably don't give a f@#$, but I sent it anyway. It's just really frustrating when you expect certain things from products you spend money on, like being able to use them. I dunno, I feel like taking all this ****** and tossing it out the window. It's no longer fun, not when you spend hours and hours troubleshooting, researching the internet, etc. Usually by the time I get whatever the "problem of the day" is solved, I don't even feel like messing with it.

  • Nagya
    Nagya Member Posts: 1 Newcomer
    I have the same problem!
  • solsta
    solsta Member Posts: 91 Helper

    @marten10bones fair point regarding the frustration.

    I have Logic Pro x and it works well but I prefer the workflow of my maschine so im sort of having to deal with certain things

    one thing I have found though is that using audio unit versions of your plugins may be more stable.

    logic pro only uses Audio Units and I had a plugin that was really going crazy on my software but after using the audio unit version, it seems like its behaving better somehow.


    so there is hope out there, I have been using maschine since mk1 the first unit I still have, its improved a lot but damn that cpu and memory usage has been a headache since back then. I used to think my earlier laptops were just bad then I ran fl studio etc on them and they were flying, this whole time maschine was just too resource intensive

Back To Top