Strange Mod Wheel Issue - Wondering if anyone else has had a similar problem...

mcwake
mcwake Member Posts: 3 Newcomer
I'm new to these forums but I've been trying to troubleshoot this for a while and I'm wondering if anyone else has run into the same issue. I've been using the Komplete Kontrol S61 on an M1 mac mini with Logic Pro for a while now, though I've only recently purchased some orchestral sound packs which really make good use of the mod wheel. I haven't really used the mod wheel for NI Kontakt instruments until now, but I've realized now that my mod wheel isn't responding in Kontakt. For comparison, the virtual keyboard responds and matches everything else I do on the keyboard, but the mod wheel doesn't react. I've cleared all MIDI assignments within Logic's preferences so I don't believe it's a channel or controller assignment issue.

The WEIRDEST thing I've discovered though is that whenever I have the instrument options window or the NI logo window open, the mod wheel suddenly starts working and responding perfectly! Anyone have a similar issue or know what might be going on here?

Best Answers

  • mcwake
    mcwake Member Posts: 3 Newcomer
    Answer ✓
    @Jeremy_NI I just gave full disk access to all relevant software and it's helping me start to fix the issue. Komplete Kontrol and Kontakt standalone used to have the same problem but after giving full access, I was able to go into the options menu and fix some things...

    In Kontakt 7, I went to File > options > MIDI and found that all inputs and outputs were set to "off". There were a few inputs listed, but I just set "KOMPLETE KONTROL S61 MK2 (port 1)" from "off" to "Port A", and did the same for (port 2). That fixed the mod wheel issue in Kontakt.

    In Komplete Kontrol, it was a similar process. I went to Edit > Preferences > MIDI. All inputs and outputs were unchecked boxes. For consistency's sake, I checked the boxes for the same inputs as in Kontakt (KOMPLETE KONTROL S61 MK2 port 1 and port 2). That fixed the mod wheel in Komplete Kontrol.

    I still can't get it to work within Logic, but there are still 3 other inputs that I haven't turned on yet which seem to be relevant to the DAW, including "Komplete Kontrol DAW", and "Logic Pro Virtual Out". Should I try checking these on in Komplete Kontrol and setting them to "Port A" in Kontakt 7? I'm not well versed in what the different ports are for, so if there's a different/better way to assign these ports, how should I do that? Any other relevant tips before I do this?

    PS - Thanks for the suggestion to give full disk access to the software. I guess I just assumed that I must have done that already when initially setting up the software, but I hadn't yet, and it definitely helped!
  • mcwake
    mcwake Member Posts: 3 Newcomer
    Answer ✓
    @Jeremy_NI UPDATE - I figured it out! After narrowing it down as a likely issue within the DAW since it works in standalone now, I realized I had conflicting MIDI assignments in Logic using CC1. I got rid of the assignments and the mod wheel works for Kontakt and Komplete Kontrol within Logic now! Thanks for your help!

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,905 mod

    @mcwake Can you reproduce this behaviour in Kontakt in standalone? Or in Komplete Kontrol in standalone?

    Have you given full disk access to Logic, Komplete Kontrol and Kontakt? How to Enable Full Disk Access on macOS

  • mcwake
    mcwake Member Posts: 3 Newcomer
    Answer ✓
    @Jeremy_NI I just gave full disk access to all relevant software and it's helping me start to fix the issue. Komplete Kontrol and Kontakt standalone used to have the same problem but after giving full access, I was able to go into the options menu and fix some things...

    In Kontakt 7, I went to File > options > MIDI and found that all inputs and outputs were set to "off". There were a few inputs listed, but I just set "KOMPLETE KONTROL S61 MK2 (port 1)" from "off" to "Port A", and did the same for (port 2). That fixed the mod wheel issue in Kontakt.

    In Komplete Kontrol, it was a similar process. I went to Edit > Preferences > MIDI. All inputs and outputs were unchecked boxes. For consistency's sake, I checked the boxes for the same inputs as in Kontakt (KOMPLETE KONTROL S61 MK2 port 1 and port 2). That fixed the mod wheel in Komplete Kontrol.

    I still can't get it to work within Logic, but there are still 3 other inputs that I haven't turned on yet which seem to be relevant to the DAW, including "Komplete Kontrol DAW", and "Logic Pro Virtual Out". Should I try checking these on in Komplete Kontrol and setting them to "Port A" in Kontakt 7? I'm not well versed in what the different ports are for, so if there's a different/better way to assign these ports, how should I do that? Any other relevant tips before I do this?

    PS - Thanks for the suggestion to give full disk access to the software. I guess I just assumed that I must have done that already when initially setting up the software, but I hadn't yet, and it definitely helped!
  • mcwake
    mcwake Member Posts: 3 Newcomer
    Answer ✓
    @Jeremy_NI UPDATE - I figured it out! After narrowing it down as a likely issue within the DAW since it works in standalone now, I realized I had conflicting MIDI assignments in Logic using CC1. I got rid of the assignments and the mod wheel works for Kontakt and Komplete Kontrol within Logic now! Thanks for your help!
  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,905 mod

    @mcwake Thanks for the update, glad you were able to fix the issue!

Back To Top