Traktor S4MK2 controller failed- bought same used model and have no output sound/headeadphone audio

sway_gold
sway_gold Member Posts: 4 Noise

Urgent-- Please help! :) My Traktor S4MK2 controller failed- bought same exact model used and now have no output sound/headeadphone audio preview. I can play, loop, basic stuff that software sees and reflects but no audio output and says : please check your output routing, I have tried all options and nothing seems to work even though I can see audio signals in hardware and software channels. Note I am using a macbook pro on el capitan and was working flawlessly with my now damaged previous S4 mk2. Bought the used one exact same model but can't get the audio. Am using Traktor Pro ver 2.11.2 11.

What audio settings do I need to do?

I checked software drivers and said i am up to date...does S4 need firmware or software update or ?

Is it because the serial number is from my damaged one and i need to enter new one?

Think its just a software setting or driver/firm ware issue but in need of guidance..

Would sincerely appreciate any and all help as I DJ every week and am losing work :(


Thank you in advance

Sway_Gold

Tagged:

Comments

  • Karlos Santos
    Karlos Santos United KingdomModerator Posts: 136 mod

    Welcome to the forum.

    Let's start with the basics.

    Please can you post screenshots of your settings in Preferences: Audio Setup and Output Routing.

    Won't do any harm to run the Device Updater for the S4MK2:

    https://www.native-instruments.com/en/support/downloads/drivers-other-files/

    It shouldn't be a Serial Number issue as the controller should just plug n play.


    Is there any reason why you haven't updated Traktor to the latest version?

    Let us know how you get on.


    Karlos.

  • sway_gold
    sway_gold Member Posts: 4 Noise

    Thank you kindly Karlos!

    I did run the Device Updater for the S4MK2: it seemed to confuse my software. But said it was up to date.

    It ran flawlessly with my now damaged S4Mk2 and when purchasing another of same exact model it recognized simple functions like play/loop/stop but no audio out or headphone preview

    Attached screenshot

    Sincerely appreciate your and anyone's

    suggestions <3

  • Karlos Santos
    Karlos Santos United KingdomModerator Posts: 136 mod
    edited April 6

    Dude you need to select Internal in Mixing Mode rather than External.

    That should reassign your Main Outputs and Monitor Outputs. If not you will be able to see which ones you require from the drop down menu.

    You could run the Setup Wizard which should solve your issue but it will change your Layouts.

    Let me know if that solves it.

  • sway_gold
    sway_gold Member Posts: 4 Noise

    Thanks Carlos appreciate you..Definitely did your suggestion.

    What should My Main Outputs be set to? I saw only internal right.internal left/ not assigned/internal mic..should i have seen Traktor out or something similar from drop down menu? This is what I fear...Traktor not an option in drop down menu...and when I change it from internal to external it says only "internal right.internal left/ not assigned/internal mic.. then i hit ok and i get the image i am posting now

    What should the drop down menu in output for my four decks be?

    Please see below image


  • Ryan_NI
    Ryan_NI BerlinCustomer Care Posts: 157 mod

    Hey there - as @Karlos Santos has mentioned, you need to select "Internal" mixing mode in the Output Routing. Then, you can select "Main L/R" or something similar for Output Master, and "Headphone L/R" for Output Monitor. Of course, you need to make sure that the S4 is selected as the audio device in Audio Setup, as well.

  • Ryan_NI
    Ryan_NI BerlinCustomer Care Posts: 157 mod

    You don't need to set the outputs for 4 decks because the S4 MK2 uses internal mixing mode. External mixing mode would be if you were using a standalone mixer like a XONE 96 or a Pioneer DJM 900 to mix with vinyl or CDJs.

  • Karlos Santos
    Karlos Santos United KingdomModerator Posts: 136 mod

    Yep 1000% you definitely need to assign Internal Mixing on the S4MK2.

    In your DM you mentioned you have run the Device Updater so you have the latest FW and drivers - Traktor ignores all other drivers and only uses the latest.

    If you put it in Internal mixing, Traktor should auto configure the outputs.

    If not they will look like this below (note this is the latest version of Traktor but it doesn't matter).


  • sway_gold
    sway_gold Member Posts: 4 Noise

    Thank you @Karlos Santos, Ryan_NI

    Appreciate you Gentlemen for your responses and advice. Turns out the S4 I temporarily bought and having this trouble had a broken soundcard!! just wow. Have since purchased another S4 and everything is well.. but one question... the latency on when I hit play on cue points seemed to be noticeably slower and not instantaneous like my previous one..is a setting I need to check/adjust?

    Thank you!

Back To Top