Can't get my Komplete A25 keyboard to work with Reaktor Blocks

hsteph
hsteph Member Posts: 4 Sine
edited January 20 in Reaktor

Greetings,

I can't get my Komplete A25 keyboard to work with Reaktor Blocks.

In the "Options", my MIDI Keyboard is activated. In the Audio and MIDI settings, the MIDI 'Inputs' status of my keyboard is ON.

When using Reaktor standalone, I can see some midi activity (Note In in green) when I type a key, but can't hear any sound. It works well however when I play some patterns. Any clue ?

(I'm using the full & latest version of Reaktor)

Best Answer

  • drb
    drb Member Posts: 2 Noise
    Answer ✓

    All of the Block ensembles you listed are driven by a clock, that is have internal sequencing.

    To hear anything you need turn on a clock to drive them.

    In general there are three possibilities.

    (1) If running standalone, turn on the Reaktor clock. (press space or use the triangle at the top.)

    (2) If running in a DAW, turn on the DAW clock (hit play or whatever).

    (3) If there is a Clock Block (there is in most if not all of the ensembles you listed), set the Block to INT.

    The ensemble will often, but not always, change the pitch of the pattern being played when you press different keys.

    HTH

    drb

Answers

  • colB
    colB Member Posts: 156 Saw

    Please post a pic of your rack or ensemble

  • Studiowaves
    Studiowaves Member Posts: 177 Tri

    Could be a simple thing like midi channel mismatch, try the omni setting in the ensemble properties and turn the midi volume up on your keyboard. It's possible the green midi activity lights on any incoming midi but if the midi channels don't match it won't respond. I would imagine that covers the basics but it seems the low and high midi notes range is backwards like the low is really the high keys and vice versa, at least it seems that way to me. Maybe it is wrong and that's your problem. Hard to say but I'd like to know if anyone else thinks the note ranges are mixed up in the properties

  • hsteph
    hsteph Member Posts: 4 Sine

    As an exemple, my keyboard is mute with the "All Four" preset from the "Curve Trax" ensemble (same behavior with all the other presets).

    If I switch to "Drive", I can use my keyboards without any issue.

  • hsteph
    hsteph Member Posts: 4 Sine

    well, more info :

    The following 'ensembles' don't work with my keyboard (all others from Reaktor Blocks are OK) :

    • blib
    • curve trax
    • duality
    • quadrapolis
    • quant FM
    • shift run
    • steps
    • XY
  • drb
    drb Member Posts: 2 Noise
    Answer ✓

    All of the Block ensembles you listed are driven by a clock, that is have internal sequencing.

    To hear anything you need turn on a clock to drive them.

    In general there are three possibilities.

    (1) If running standalone, turn on the Reaktor clock. (press space or use the triangle at the top.)

    (2) If running in a DAW, turn on the DAW clock (hit play or whatever).

    (3) If there is a Clock Block (there is in most if not all of the ensembles you listed), set the Block to INT.

    The ensemble will often, but not always, change the pitch of the pattern being played when you press different keys.

    HTH

    drb

  • hsteph
    hsteph Member Posts: 4 Sine

    Thanks, I suspected something like that (auto generation of sound). Reaktor is a special animal to be comfortable with ! ;)

  • colB
    colB Member Posts: 156 Saw

    I suspect that drb is correct that you need to start the clock. I your pic, the clock is not running, and set to INT(ernal) so you need to hit the play triangle on the clock block.

    I also noticed that you are using a modified Note In Block. Not ideal if you are having problems with note input ;)

Back To Top