What Firewall Rule is needed to allow Native Access 2 to operate (Win10)

Snipey
Snipey Member Posts: 3 Newcomer

I previously had a rule to allow NA to make calls in and out of my Windows 10 PC.

I have recently upgraded to NA2 but I found that applying the same simple rule for this app is not sufficient. NA2 will not work unless I switch off the Firewall.

What Firewall Rule(s) are required to allow NA2 to operate please?

I am using the standard Windows Defender Firewall.

Tagged:

Answers

  • Sunborn
    Sunborn Member Posts: 2,161 Expert
    edited January 17

    Usually, with authorized (and digitally signed) Windows applications, you don't need any special Firewall rules, just the default ones. They pass automatically.

    However, if you use an extremely strict levels of security, or you have made a manual configuration, problems might occur. Usually if you are a simple home user and not some corporation you don't need extremely strict levels of security.

    I advice to use the recommended (by the antivirus) level of security and not a higher one.

    I do not use Windows Defender but i can check my Avast later, to tell you what kind of configuration it has for Native Access.

    For a quick solution. simply add Native Access to the exclude list (to bypass all rules) or at least make sure that ports 80 and 443 are open and allowing incoming connections.

  • Snipey
    Snipey Member Posts: 3 Newcomer

    Thanks for the suggestions. The reason I have specific rules set up is historic (PC is 10 yrs old), afaik that's how it had to be done. Usually adding a rule for a new app just works. Indeed it worked for Native Access 1.

    I tried fiddling around with the FW settings again just now to check against what you suggested and it doesn't seem to make any difference whether I have an inbound and outbound rule (which both allow all ports and any protocol) or if I add Native Access to the FW exceptions list.

    I'm wondering if the issue is related to the NTKDaemonService although I thought if the service was associated with an allowed app then that should be ok. But I don't really know. All I do know is that if I switch the FW off it all works. I raised a ticket with NI Support 2 weeks ago but they haven't replied yet. To be fair my issue isn't a high priority one as I have a workaround, its just an inconvenience.

Back To Top