Pro-53 on launch gives "Error in controlmap.txt at line 1

Sam916
Sam916 Member Posts: 2 Member

Hi, I am new to this forum; and am asking the question for the first time.

In Logic Pro X (v10.4.6) on Mojave, when I insert PRO-53 legacy plugin, I see the following error (or rather warning).

The first line of the file is: PRO52CTLMAP1

Can someone please help me resolve the issue?

If I click OK, the plugin is inserted on the track and works just fine.


Thanks - Sam.

Best Answers

  • Milos
    Milos Member Posts: 1,867 Pro
    Answer ✓

    Well, if you clicked OK and everything worked just fine, then you had no issues.

    It is nothing to be worried about.

  • Kubrak
    Kubrak Member Posts: 2,764 Expert
    Answer ✓

    It is not possible to authorise Pro-53 for few years. So, if it is a new installation, it will run as Demo.

    https://support.native-instruments.com/hc/en-us/articles/360006053397-Service-Center-and-Legacy-Products-End-of-Life

  • Sunborn
    Sunborn Member Posts: 2,193 Expert
    Answer ✓

    Haven't see this dinosaur for almost a decade!

    Surprised that it still working 👍️

    If i remember well, the controlmap.txt was about how MIDI controller numbers assigned to the Pro-53 parameters. If controlmap.txt contains any entry that isn’t supported by the Pro-53, you’ll get an error message like yours, the next time you launch the program, and then the controller map is just not used.

    Not a big deal. It's annoying yes, but... it should be expected from such an old app... :-)

  • Sam916
    Sam916 Member Posts: 2 Member
    Answer ✓

    @Sunborn, thanks for you comment!

    The error is annoying - but the message is not meaningful. The first line - as the error message shows - looks innocent. I am curious about what is offending the plugin...

    If you have a similar file, can you please upload it - for me to compare? BTW, I have never touched this file; and now, all of a sudden, the plugin shows the error.

    Thanks, again.

Answers

  • Milos
    Milos Member Posts: 1,867 Pro
    Answer ✓

    Well, if you clicked OK and everything worked just fine, then you had no issues.

    It is nothing to be worried about.

  • Kubrak
    Kubrak Member Posts: 2,764 Expert
    Answer ✓

    It is not possible to authorise Pro-53 for few years. So, if it is a new installation, it will run as Demo.

    https://support.native-instruments.com/hc/en-us/articles/360006053397-Service-Center-and-Legacy-Products-End-of-Life

  • Sunborn
    Sunborn Member Posts: 2,193 Expert
    Answer ✓

    Haven't see this dinosaur for almost a decade!

    Surprised that it still working 👍️

    If i remember well, the controlmap.txt was about how MIDI controller numbers assigned to the Pro-53 parameters. If controlmap.txt contains any entry that isn’t supported by the Pro-53, you’ll get an error message like yours, the next time you launch the program, and then the controller map is just not used.

    Not a big deal. It's annoying yes, but... it should be expected from such an old app... :-)

  • Sam916
    Sam916 Member Posts: 2 Member
    Answer ✓

    @Sunborn, thanks for you comment!

    The error is annoying - but the message is not meaningful. The first line - as the error message shows - looks innocent. I am curious about what is offending the plugin...

    If you have a similar file, can you please upload it - for me to compare? BTW, I have never touched this file; and now, all of a sudden, the plugin shows the error.

    Thanks, again.

  • Sunborn
    Sunborn Member Posts: 2,193 Expert

    Unfortunately no, i don't have... it is many years that i left this plugin behind

    however, the syntax in your screenshot is correct, it shouldn't produce an error, but as i said it is an old plugin and most probably it has some incompatibilities with more modern software.

    you may try a "trick"... back it up, then edit it, remove the first line (and the empty space, so your text start with the ; symbol of the next line), save it, and try the plugin.

    or just delete it completely... in this case Pro-53 it will use the default settings... if you do not control some midi devices with it, you don't really need it. :-)

Back To Top