Latency with Komplete + Logic.

Huangqi
Huangqi Member Posts: 6 Newcomer

I have a new komplete keyboard. With a new empty Logic session, I hit a key and sound is instant. Yet when I create a new software instrument (track) with a previous session that has already recorded audio tracks I get a very obvious delay when I hit the key. This happens even if I am not in play or record mode (idle). Changing buffer size has no effect. Also, recording audio tracks has no latency. Brand new Mac Studio + updated Logic software.

Any ideas? Thanks.

Best Answer

  • Huangqi
    Huangqi Member Posts: 6 Newcomer
    Answer ✓

    Thanks ALL, I found the low latency check box and it solved the problem!

Answers

  • electronicparts
    electronicparts Member Posts: 9 Member

    I have a similar setup and found you MUST use the Software Latency Button turned on when you play or record midi in Logic. Regardless of your buffer setting. You didn't mention trying this but that creates this exact problem for me.

  • Huangqi
    Huangqi Member Posts: 6 Newcomer

    Thanks for the response. First, where is the software latency button you mentioned? Do you mean in logic? My issue occurs though even when I am Not playing or recording. Meaning just hitting a key with NOTHING running at all in LOGIC. But maybe this button will fix it. Thanks for any additional info.

  • Huangqi
    Huangqi Member Posts: 6 Newcomer

    One more bit on info. If I turn off all plugs, still massive delay.

  • Maciej Repetowski
    Maciej Repetowski Member Posts: 369 Pro

    What is your audio latency compensation set to? (In audio preferences).

    what is your buffer setting? M chips work better with small buffer under load (counterintuitive), 32, 64 or 128 buffer?

    do you have any lookahead plugins on audio tracks, groups or stereo sum? Like adaptive limiter and such?

    You should have little R icon toggled on with software instrument track. This prioritises that track and lowers its latency by reserving a core for it. Even if you don’t record and just noodling on a keyboard.

    Let me know if any of this helps.

    And don’t run Logic in Rosetta mode on M chips unless you have a plugin which needs it.

  • Huangqi
    Huangqi Member Posts: 6 Newcomer
    Answer ✓

    Thanks ALL, I found the low latency check box and it solved the problem!

Back To Top