maschine mikro mk3 in midi mode on M1 Mac -- invisible/no signal

ememememe
ememememe Member Posts: 3 Newcomer

hi, my mikro mk3 works fine in maschine plugin or standalone, but I can't get my mac m1 to recognize it as a midi device when it's in midi mode. It doesn't show up at all in the mac os built in "Audio MIDI Setup", unlike the S49 mk2 and other midi devices, and I can't see any signal coming from the device in my DAW. As I said, it works great in Maschine software, so it's not a usb cable issue or something like that. It even shows up in Controller Editor and I can change midi maps etc. But it doesn't show up in my DAW or in Midi Studio (in Audio MIDI Setup, from mac os). I did the NI troubleshooting that I've seen recommended, but no luck (my device is also working perfect in maschine). What am I missing?

Answers

  • D-One
    D-One Moderator Posts: 2,753 mod
    edited December 2023

    Sounds like something might be wrong with the NI background services in charge of MIDI Mode or with the driver. What OS version, Ventura? Sonoma?

    For the driver reinstalling Maschine usually fixes it, and for services sometimes too.

    In System Preferences> General> Login Items are both NIHardwareAgent.app and NIHostIntagrationAgent.app listed?

    While the MK3 is in MIDI Mode launch Activity Monitor and search for "NIH" and see if they also show up there.


  • 6xes
    6xes Member Posts: 600 Pro

    is the mikro mk3 has the words virtual input beside it.. ie mikro - virtual input 1

    then try going into controller editor... and preferences and change it to. mikro - 2... it then requires a disconnecting of the USB and replugging it in

    then it will be recognised as a standard midi device, at which point you can choose to operate it as micro 2 but all your controller editor mappings need to be copied across... or you could repeat the process again & change it back to micro - 1. and it will have the virtual input removed....

    this occurs with the most Maschine controllers, having a virtual input beside their name.. which can cause the controller to not show up as a midi device in some programs

    goodluck

  • ememememe
    ememememe Member Posts: 3 Newcomer

    Thanks! Unfortunately that didn't fix the issue. I'm on Sonoma. I re-installed Maschine 2 Essentials. I went into Midi mode (says so in the display) and verified that these two NI services/daemons/apps are set as login items and that the processes are actually running (in activity monitor). I still don't see the mikro in the Audio MIDI Setup. But as before it works in maschine plugin, and I can open it in Controller Editor (and change colors etc).

    As for 6xes' comment, I'm not sure. Where would I look for this 'mikro - virtual input'? I went into controller editor but in preferences I couldn't see 'virtual input' or anything (and besides, I didn't see an option to change the device name). In the preferences of the Maschine app I did see 'virtual input' as a potential midi in, but it was not selected.

    I feel like I'm missing something basic, but googling around I find very few posts with similar issues, and those that look similar got resolved by rebooting or reinstalling maschine or something like that.

  • 6xes
    6xes Member Posts: 600 Pro

    when in controller editor.. select preferences and then select mikro ... I'm not sure if the mikro allows you to select mikro - 2 like it shows in the screenshot...

    as the difference between your mikro and my Maschine jam... is i have x2 of them, where it allows me to select 2 other options


  • ememememe
    ememememe Member Posts: 3 Newcomer

    Okay thanks. It looks different for me, I guess mikro is different from jam, but no 'virtual input' at least. see screenshot.


  • D-One
    D-One Moderator Posts: 2,753 mod

    Then I am leaning towards it being due to Sonoma, it's not officially supported yet.

    There's other Sonoma specific issues, this one for example:

    https://community.native-instruments.com/discussion/comment/121081#Comment_121081

  • 6xes
    6xes Member Posts: 600 Pro

    one final thing you could try...

    when Maschine is running and your mikro is connected..

    disconnect the usb cord of the mikro for a couple of seconds and then reconnect it...

    and then check inside Maschine/preferences/midi to see if there is another entry ie. mikro mk3 without the mikro mk3 - virtual input

    if the mikro appears in the midi list without the virtual input attached to the mikro mk3...


    if this has not worked... then I don't know any other method to remove the virtual input

Back To Top