Midi Keyboard only playing on Port A Ch. 1

PulseStar
PulseStar Member Posts: 21 Member

Hi Everyone

Has anybody had the above problem with Kontact 7 when having say 5 or 6 instruments loaded up in one instance of Kontact ?

I have no problems playing seperate sounds in my DAW (Cakewalk by Bandlab) when using Kontact 6 but cannot do the same in Kontact 7.

Ideas anybody?

«1

Answers

  • Sunborn
    Sunborn Member Posts: 2,128 Expert
    edited December 2023

    Go on each instrument and change the Midi channel from 1, to Omni

    or even better, for a global solution, go to "Options --> Handling ---> Midi Channel assignments for loaded patches" and change the value to "Assign to Omni"

  • mykejb
    mykejb Moderator Posts: 807 mod

    @PulseStar Are you trying to play each of the instruments inside Kontakt from separate MIDI tracks in Cakewalk? So when you click MIDI track one you play/record MIDI for one of the instruments, when you click MIDI track two you play/record for another instrument etc?

    -- Mike

  • PulseStar
    PulseStar Member Posts: 21 Member

    Thanks for answer ... just turned off after a frustrating day. I'll try tomorrow.

    Hi Mike. Yes

  • PulseStar
    PulseStar Member Posts: 21 Member

    Hi Again

    If I load 3 instruments into a Standalone Kontact 7 and set each patch to Port A , 1, 2 or 3, then when I play my Oxygen Pro it doesn't matter which patch I select ( 2 or 3) it always plays Ch.1. If I play Kontacts keyboard then again the only sound comes from Port A Ch.1. If I select instrument 2 or 3 it shows in the mixer (3 seperate channels) but no sound.

    Afraid I'm at a loss. :-(

    Sunborn...Tried these but no change.....thanks anyway.

  • mykejb
    mykejb Moderator Posts: 807 mod

    @PulseStar Here's a walk-through for two instruments, hopefully it'll cover your problem as long as I've remembered right and I've understood what you want!

    First, load Kontakt onto a track, don't assign a MIDI device to it. Load your two instruments into Kontakt. Set instrument 1 to Port A, channel 1, set instrument 2 to Port A, channel 2.

    Create a MIDI track with your keyboard as input. Set the output to the Kontakt track. On the left hand side in the MIDI track inspector set the output MIDI channel to 1. Do the same with a second MIDI track, but set the output MIDI channel to 2.

    You should now be able to activate one or the other MIDI track and it'll play the relevant instrument.

    I can drop some screenshots later if that'll help, but I'm on a laptop at the minute without Cakewalk installed. If it doesn't work yell and I'll check I didn't miss a step later when I get home later from Christmas shopping.

    -- Mike

  • PulseStar
    PulseStar Member Posts: 21 Member

    OK. I'll check this morning and let you know. Thanks

  • Sunborn
    Sunborn Member Posts: 2,128 Expert

    @PulseStar i understand now why this is happening now and didn't happened with Kontakt 6.

    Try this one in Stand Alone first (it should be apply in a DAW too):

    The old style libraries or the custom instruments (like this one i made in the example below), the Midi channel configuration was clear and you could change your channel instantly (In the example below i have it on channel 3)


    But, on the new libraries this is not straightforward anymore!

    You have to enter the edit mode (by clicking the key on the top-left) of the instrument first! Then you will see the Midi configuration and you can change it easily.

    See the example below (assigned to Midi channel 2)


    I hope that this, will solve your problem! :-)

  • mykejb
    mykejb Moderator Posts: 807 mod

    Or you can click the little "i" icon and change it there

    -- Mike

  • PulseStar
    PulseStar Member Posts: 21 Member

    I think i have now tried everything. Whatever I do my keyboard will only play on ch. 1 with Kontact 7.

    I must be missing some basic setting but cannot see it. By the way I am not a newbie at this...I've been using it for years now.

    Thanks for your help Mike, and everyone else

  • mykejb
    mykejb Moderator Posts: 807 mod

    Screenshots incoming, an example with Hybrid Keys as instrument 1 and Clavinet as instrument 2

    First, Load Kontakt into Cakewalk, set up your MIDI channels like this. You don't need any MIDI input going directly to the instance of Kontakt.

    Create two MIDI tracks and set them up like this

    MIDI channel 1 which will go to Hybrid Keys

    The important bits are on the left. At the bottom is O 1-Kontakt 7. That sends the output to the Kontakt instrument. At the top you'll see "C 1: Kontakt 7" - that sends the output to channel 1 of the Kontakt instrument. Set the input to your keyboard where it says "I KOMPLETE " at the bottom left of the screenshot.

    Set up the second MIDI channel like this

    The difference is the top left setting where it says C 2: Kontakt 7. That means it's sending the output to channel 2 of the Kontakt instrument.

    Now you should be able to click on the MIDI channels so the name is highlighted and the keyboard output will be sent to the correct Kontakt channel.

    I think that about covers it, but yell if you're still having trouble.

    -- Mike

  • PulseStar
    PulseStar Member Posts: 21 Member

    Hi Mike

    Set up as you've described. Kontact keyboard plays as it should. As usual my Oxygen pro only plays Channel 1.

    Do you think this a Kontact problem , Cakewalk by Bandlab problem or has my keyboard given up ?

    Must say though , this has only happened since upgrading from 6 to 7.

  • mykejb
    mykejb Moderator Posts: 807 mod

    I'm kinda stumped then. I just loaded the project here and it worked fine even with a different MIDI keyboard.

    I'm happy to send the Cakewalk project as a last resort if you want to load it and give it a go?

    -- Mike

  • PulseStar
    PulseStar Member Posts: 21 Member

    There is definitely something strange going on.

    Just now everything played on channel 2.

    Left it for 10 mins and it now plays channel 1 again.

    I'll post 2 screen shots to see if anyone can make out if I'm doing something wrong.

    Thanks for looking. Alan

    Should I reinstall Kontact?

  • mykejb
    mykejb Moderator Posts: 807 mod

    Any chance you can screenshot rather than take a picture? Easiest way is the Windows snipping tool.

    I've attached my cakewalk project which is really simple - two instruments in a single instance of Kontakt with two MIDI tracks feeding it. See if that works for you. It uses a couple of NI instruments, but if you don't hav them you can swap with something you own.

    -- Mike


  • PulseStar
    PulseStar Member Posts: 21 Member

    Hope this works Mike.



Back To Top