KONTAKT 7.6.1 on MacOS CATALINA 10.15.7 on older MacPro 4.1/5.1

Apollobeat
Apollobeat Member Posts: 9 Member
edited December 2023 in Kontakt

For all users who want to continue using "Native Instruments Kontakt 7.5" and up to Kontakt 7.6.1 under Catalina 10.15.7, I have a little surprise for you.

I suspect that some vendors are trying to make us believe that their products require higher versions of Mac OS in order to increase sales. 

I don't want to judge this any further, but as I have patched a 4.1 MacPro to 5.1 on my "old" cheese grater from 2009, which runs NI Kontakt 7.6.1 (minimum system requirement Mac OS 11) under Catalina 10.15.7 without any problems, this suspicion is obvious. 

First of all, I have an official licence for Kontakt 7 and have installed it correctly. 

         

My system configuration:

         MacPro (Early 2009) 4.1 patched to 5.1

         MacOS Catalina 10.15.7

         2x 3.46GHz 6-Core Intel Xeon

         48GB 1333MHz DDR3

         Radeon RX 580 8GB


Important:

The procedure described below is at your own risk and I accept no liability for any damage that may occur. 

I would also like to expressly point out that this should only be carried out by experienced users.


PLEASE READ CAREFULLY AND COMPLETELY TO THE END.

1.    install version Kontakt 7.4.2 from Native Instruments correctly.

2.    download version Kontakt 7.6.1 and open the installer (*.pkg) of Kontakt e.g. with "Pacifist 4.02". 

3.    Extract the contents of the K7.6.1 installer displayed in "Pacifist" to a new folder (e.g. on the desktop).

4.    search for the installed "Kontakt 7.app" (7.4.2) in the Finder. Display the package contents of the original "Kontakt 7.app" (7.4.2) and switch to the MacOS folder. The UNIX file "Kontakt 7" is located there. Do the same in a new Finder window for the "Kontakt 7.app" (7.6.1) version extracted with Pacifist. 5.

5.    copy the UNIX file "Kontakt 7" from the MacOS folder of version 7.6.1 and replace it in the MacOS folder of version 7.4.2.

6.    open the file "info.plist" with "Textedit" or "BBEdit" in the root directory of version 7.4.2. 

7.    change the version entries in lines 6, 8 and 10 from "7.4.2" to "7.6.1". 

That's it! "Kontakt 7.app" is now on version 7.6.1!

The same procedure is used for the VST3 and Audiounit versions of Kontakt7.

Since I am an enthusiastic NKS user and work a lot with Komplete Kontrol software, it is very important to me that current libraries continue to work with KK. That's why editing the info.plist (see point 7) is very important!

VERY VERY IMPORTANT !!!!

1. ALWAYS MAKE A BACKUP OF YOUR ORIGINAL FILE(S)/FOLDER BEFORE EDITING! 

-> NO BACKUP - NO PITY!

2. AFTER THE UPGRADE DESCRIBED ABOVE, THE EDITED KONTAKT 7 FILES MAY NO LONGER BE MOVED, COPIED OR RENAMED! 

Your MacOS will notice this and since the minimum requirements are not met, MacOS will block access to the app and the plugins. 

In such a case, you would have to repeat the process described above. 

However, as long as you leave the data in the locations, everything works perfectly, without any problems or restrictions.

So make sure that the files to be edited (standalone app, audio unit, VST and VST3) are already in the right place before editing!

Tagged:

Comments

Back To Top