No sound after multiple attempts to fix

Hey all, I'm dealing with an audio routing issue that I have tried to address multiple ways with no luck. Any help is appreciated. Here's my setup and details of the problem:

2019 Macbook Pro, running macOS Catalina 10.15.7

Traktor Kontrol Z1

I'm getting zero sound through the main outputs. I have double and triple checked the soundboard and speakers to make sure everything is working there - it all works when a friend plugs their Mac into the Z1 and plays music. Also the headphone jack on the Z1 works fine for cueing. Audio setup in Traktor is as follows:

Audio device - Traktor Kontrol Z1, Sample rate 48000 Hz

Output routing - Monitor is 3. Headphone left and 4. Headhpone right (which works), and Master is 1. Main Left and 2. Main right.

When playing a track I can see both the track indicator lighting up (both in Traktor and on the Z1) and the master indicator at the top in Traktor also lighting up. But no sound.....

Then I discovered something, and here's where it gets weird - the master audio is being routed to the headphone jack on the Macbook. Plug my headphones directly into the Macbook, and there it is, volume controlled by the Z1. *****??? I've looked in Audio Midi Setup on Mac, but can't manipulate any of the settings for the Z1 there.

Just for good measure I have tried using the built in Macbook audio - cannot get anything to play through the speakers. Same story - the headphone jack does work, and plays the main output. I also double checked other apps - Music and Spotify work fine through the Macbook speakers (haven't tried them through the Z1, I find that's finicky).

Also I updated Traktor just to make sure, no change. And I've rebooted the machine multiple times, and also reset the PRAM.

ANY help would be SUPER appreciated, I'm stumped and very frustrated. Had to transfer all my tracks very last minute to a friend's computer yesterday in order to play a set since we couldn't get any sound through the system out of my computer!

Thanks in advance, hoping someone sees something I don't!

Harwood

Tagged:

Best Answer

  • harwood.ferguson
    harwood.ferguson Member Posts: 2 Noise
    Answer ✓

    Fixed! I have Loopback running in the background, and sometimes choose Traktor as a source for a whole different purpose. I had assumed that Loopback would tap a portion of the Traktor signal, while sending the rest of it to the main output, effectively duplicating the main signal. Turns out that's not true - Loopback appears to take over the entire signal, thus blocking it from going to the main output.

Answers

  • harwood.ferguson
    harwood.ferguson Member Posts: 2 Noise
    Answer ✓

    Fixed! I have Loopback running in the background, and sometimes choose Traktor as a source for a whole different purpose. I had assumed that Loopback would tap a portion of the Traktor signal, while sending the rest of it to the main output, effectively duplicating the main signal. Turns out that's not true - Loopback appears to take over the entire signal, thus blocking it from going to the main output.

Back To Top