IMPORTANT PLEASE HELP

UTKU
UTKU Member Posts: 1 Newcomer

MAC PRO RETINA MID 2012

I AM USING CATALINA 10.15.7 VERSION, BUT WHEN I DOWNLOAD TRAKTOR S2 MK3 DRIVER, IT SAYS IT IS NOT COMPATIBLE WITH THIS COMPUTER. I CANNOT UPGRADE MY VERSION TO 11, WHAT SHOULD I DO?


THE PROGRAM WAS RUNNING ON THIS COMPUTER PREVIOUSLY. BUT I DELETED IT AND WHEN I WANTED TO INSTALL IT AGAIN IT GIVEN THIS ERROR DURING THE INSTALLATION


PLS write me : [email protected]

Answers

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,537 mod

    Install Big Sur on your mac.

    The driver you downloaded is probably .exe file (Windows)

Back To Top