Can't record mixes after upgrading to Traktor Pro 3

After upgrading to Mac OS Sonoma 14.1.1 and Traktor Pro 3 (3.10.1) everything functions as expected except the fact that I CANNOT RECORD MIXES. All preferences/settings have been retained (i.e. Input/Output Routing; Mix Recorder settings). All permissions for all Traktor/Native Instruments apps and devices (Audio 10; Native Access) are enabled. NOTHING has changed except - I just can't recored. I get this pop-up:

Any help would be greatly appreciated.

Tagged:

Best Answer

  • adam pudney
    adam pudney Member Posts: 6 Member
    Answer ✓

    Lord Carlos.

    You're an absolute GENIUS! I did both (i.e. removed the prefix entirely and let Traktor just give it the time stamp, and also created a dummy directory to see if the recording would be diverted elsewhere) and HEY PRESTO! Hit record and away it went. I reckon it was the slashes though. Like when you try and save files and the filename has slashes - Macs just don't like them. Never been problem before but I'll know not to use them in future.

    I can't thank you enough. This issue has had me frustrated for over a week (NI couldn't even solve the problem up to this point) and you've fixed it in the space of an hour. Thanks for your time and attention.

Answers

  • Milos
    Milos Member Posts: 1,836 Pro

    Maybe you should try to change the audio engine.

    I hope it works.

  • adam pudney
    adam pudney Member Posts: 6 Member

    Thanks for the suggestion Milos, but I would need more specific instructions than that. Not sure what the audio engine is or where I would find it.

  • Milos
    Milos Member Posts: 1,836 Pro

    Try to find it in the settings and preferences.

    Just like in every DJ program or DAW.

  • adam pudney
    adam pudney Member Posts: 6 Member

    If you mean selecting the Audio 10 as the default input/output device in the MIDI setup, I've already checked that. Like I say, none of that was affected by the upgrade.


  • lord-carlos
    lord-carlos Member Posts: 2,018 Expert
    edited November 2023

    I think Mac OS has CoreAudio only, it's not like windows where you have WasAPI and ASIO

    ______________

    I notice gain and filter are grayed out, are you running in external mixing mode?

    What hardware are you using?

  • adam pudney
    adam pudney Member Posts: 6 Member

    Hi Lord Carlos. Thanks for your attention to my issue.

    Yes, I'm mixing in external mode (I don't use internal). I use NI Audio 10 interface, Allen & Heath mixer, Technics decks, Traktor timecode discs. Pretty old school, I don't even use a Traktor controller. Like I say, none of my set up or settings have been altered by, or since the upgrade.

    I'm baffled by this. I can't be the only person who uses this setup that is having this problem.

  • lord-carlos
    lord-carlos Member Posts: 2,018 Expert

    Can you show us your input routing and mix recorder settings?

  • adam pudney
    adam pudney Member Posts: 6 Member

    My friend, they're standard and I've checked 'em so many times because I know that's usually the problem in these cases. Like I say, they remained unchanged after the upgrade. Here they are anyway:


  • lord-carlos
    lord-carlos Member Posts: 2,018 Expert

    Even if they are default for you it might help us get to know your setup better. 🙏Thank you for your cooperation.

    Can you try to remove the prefix and try again? The slashes might give it trouble.

    If that does not help .. just for the fun of it, try another directory.

  • adam pudney
    adam pudney Member Posts: 6 Member
    Answer ✓

    Lord Carlos.

    You're an absolute GENIUS! I did both (i.e. removed the prefix entirely and let Traktor just give it the time stamp, and also created a dummy directory to see if the recording would be diverted elsewhere) and HEY PRESTO! Hit record and away it went. I reckon it was the slashes though. Like when you try and save files and the filename has slashes - Macs just don't like them. Never been problem before but I'll know not to use them in future.

    I can't thank you enough. This issue has had me frustrated for over a week (NI couldn't even solve the problem up to this point) and you've fixed it in the space of an hour. Thanks for your time and attention.

Back To Top