Fix to prevent MIDI controller from hiding track names with Kontakt in Pro Tools' MIDI preferences

JKN
JKN Member Posts: 2 Newcomer
edited November 2023 in Tech Talks

Since upgrading to Pro Tools 2023.9, plugging in my controller (Hammer 88) makes it impossible to see in "Preferences > MIDI" the names of tracks with Kontakt (6.8 and 7.7) inserted. (See pic 1.) But if I also insert Toontracks' EZKeys in a different track, then I DO see all track names in Preferences. Unplugging the controller also lets me see the track names (see second pic). Has anyone else found this? Does anyone have a solution other than my little workaround or installing one or more earlier versions of PT?

Thanks!

JKN



Answers

  • Milos
    Milos Member Posts: 1,867 Pro

    If you have the automation inside the DAW, try to use that instead of MIDI learn.

    It might help.

  • JKN
    JKN Member Posts: 2 Newcomer

    Thanks for the suggestion, but I'm not sure what you mean. On these tracks, I'm not using automation, just plugging the MIDI controller in, which deactivates the track name in the MIDI Preferences tab when assigning which track the controller should control.

  • Milos
    Milos Member Posts: 1,867 Pro

    With automation feature inside your DAW, you can chokse which knob or setting you can control inside the instrument with automation.

Back To Top