How do I associate Instruments with Kontakt 7 instead of Kontakt 6?

Options
Alex-S49
Alex-S49 Member Posts: 19 Member

When I'm loading instruments from my Komplete Kontrol library it always tries to load with Kontakt 6, instead of Kontakt 7 and then says "Your version of Kontakt is too old".

I have both installed and I understand it is okay to keep both. How can I fix this so I don't have to load the Kontakt 7 VST first and then open the instrument into it? This is extra steps and its much easier to browse though the library and open from there.

Best Answers

  • Alex-S49
    Alex-S49 Member Posts: 19 Member
    Answer ✓
    Options

    Hi Milos,

    Thanks but I've now realised my question was a bit naive (due to being quite new to the NI concepts).

    I now see that there are several instruments with a "2.0" NKI file (eg Analog Dreams, Ethereal Earth, Hybrid Keys etc) and these ones load into Kontakt 7 only but the ones without "2.0" load into Kontakt 6 okay.

    Some are obviously only available for Kontakt 7 (in the case of Ignition Keys for example).

  • Alex-S49
    Alex-S49 Member Posts: 19 Member
    Answer ✓
    Options

    That seems to have worked. I removed K6 and updated K7 to the latest.

    Happy composing!

    Alex

Answers

  • Milos
    Milos Member Posts: 1,995 Guru
    Options

    Alex, you can try to update or reinstall Komplete Kontrol.

    It might fix the issue.

  • Alex-S49
    Alex-S49 Member Posts: 19 Member
    Answer ✓
    Options

    Hi Milos,

    Thanks but I've now realised my question was a bit naive (due to being quite new to the NI concepts).

    I now see that there are several instruments with a "2.0" NKI file (eg Analog Dreams, Ethereal Earth, Hybrid Keys etc) and these ones load into Kontakt 7 only but the ones without "2.0" load into Kontakt 6 okay.

    Some are obviously only available for Kontakt 7 (in the case of Ignition Keys for example).

  • Alex-S49
    Alex-S49 Member Posts: 19 Member
    Options

    I just realised I haven't actually completely resolved my problem.

    Although I now understand there are different NKIs for Kontakt 6 and 7 and I can choose the appropriate one from the on screen application, when you are using the Komplete keyboard, these are merged together (eg all Ethereal Earth is listed together). So some of them are not loading via the Komplete keyboard because it tries to load in Kontakt 6 by default and I get the error "Your version of Kontakt is too old ....".

    How can I make it use Kontakt 7 by default. Do I need to uninstall Kontakt 6?

  • Milos
    Milos Member Posts: 1,995 Guru
    Options

    Not sure.

    You can try to uninstall Kontakt 6 if you want.

    I uninstalled it because I don't need it anyway (I have Kontakt 7 full version)

  • Alex-S49
    Alex-S49 Member Posts: 19 Member
    Options

    Hi Milos and thanks for the advice.

    I think I will do that then. Since the installation of Kontakt 7 didn't upgrade/replace Kontakt 6 I thought perhaps that might still be needed for some things.

    Hopefully removing Kontakt 6 will make all the current associations open in Kontakt 7 instead.

  • Milos
    Milos Member Posts: 1,995 Guru
    Options

    No problem.

  • Alex-S49
    Alex-S49 Member Posts: 19 Member
    Answer ✓
    Options

    That seems to have worked. I removed K6 and updated K7 to the latest.

    Happy composing!

    Alex

  • Monochrome
    Monochrome Member Posts: 1,198 Expert
    Options

    Just to clear the confusion: NI recently released new versions (MK3) of their keyboards. To let instruments take more advantage of the new keyboard functions, NI updated several Kontakt libraries to Kontakt 7.6, resulting in a "2.0" version.


Back To Top