Issues with Traktor X1 Mk3 & Native Access 2

Leon Mester
Leon Mester Member Posts: 10 Newcomer

Despite having a Mac up to date (Os 10.15.7) Native Access 2 isn't compatible and can't be installed... So, i've installed previous compatible version of Native Access (3.5.3) and register my new X1 MK3.

Also gave "Full Access Disk"permissions to all NI and Audio app in the system preferences already.

when starting Traktor and plugging the X1, nice display appears with Led, then OFF, and only the middle button "orange 3 lines" remains ON.

From here, I can only switch the controller to Midi Mode and Map it through Traktor. 

I can also see the controller into my "Audio & Midi Preferences" on the Mac, BUT NOT on the NI Controller Editor or NEITHER into Traktor preferences (left column).

Tried with/without power adapter, also tried different USB cable...

Controller seems to be working when I map some functions myself in MIDI MODE, but I unfortunately can't get the most of the new features (Screens with info and Led mapping) this way.

Any idea please?


Best Answers

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert
    Answer ✓

    For Traktor X1 mk3 you need Traktor 3.10, which you can only get with newest version of Native Access.

    Maybe see the native access forum for help or write support. But with traktor 3.5 you will not get your x1 mk3 to work.

  • dariodelima
    dariodelima Member Posts: 43 Advisor
    edited October 25 Answer ✓

    Your problems will stem from Osx Catalina, X1Mk3 only works on Traktor 3.10 and sadly traktor 3.10 no longer runs on or supports Catalina OSX. So to install the latest Traktor 3.10 and use your X1 mk3 you need to update your osx, sadly. that goes for native access 2 also.

    Not sure what year your macbook is, if 2012 then sadly that also ends updates to osx at Catalina and you can not update to a newer OSX, if you have a newer macbook then you can update your osx and then you will be able to run Traktor 3.10, x1 mk3 and native access 2

    Hope that helps you find a solution, i was in the same boat had my 2012 macbook and it is still running good, but as the last osx to support that year of model mid 2012 was catalina, i had to upgrade and got a M1 pro in order to go with Traktor 3.10 and onwards. it was about time anyways to upgrade my laptop, 2012 gave me a good 10 years and not one issue or crash in all those years. 🙏

    there you can see Traktor 3.10 specifications. Supported on OSX 11 and upwards.

«1

Answers

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert
    Answer ✓

    For Traktor X1 mk3 you need Traktor 3.10, which you can only get with newest version of Native Access.

    Maybe see the native access forum for help or write support. But with traktor 3.5 you will not get your x1 mk3 to work.

  • dariodelima
    dariodelima Member Posts: 43 Advisor

    You can also download 3.10 from NI website itself if you are having issues getting it with NI access, secondly X1mk3 does not show up in control editor as previous x1's did.

  • Leon Mester
    Leon Mester Member Posts: 10 Newcomer
    edited October 23

    @lord-carlos thank you for your prompt reply.

    You are the first to give me "the cause" of the issue.

    Thing is, my Mac is compatible but won't install NATIVE ACCESS 2 for some reason.

    As i can see @Julian242 is experiencing the same problem.

    I guess an "updated version" of Native Access 2 for Mac OS 10.15 users will come soon...

    @dariodelima thank you, but when going on the website to try download Traktor, their link sends me to NATIVE ACCESS again...

  • dariodelima
    dariodelima Member Posts: 43 Advisor
    edited October 24

    Follow the link and at bottom of first post you will find the link to 3.10.1 beta, Do not worry about it being beta, it is identical to the RC version except for the fact thhat on beta version they fixed flickering screens for windows. you can safely use that till the next version comes out.

    Also your issue with Native Access 2, what are the specs of your macbook? are you using a m1 or m2 or a previous year macbook, Native Access 2 also your osx is not compatible with certain versions anymore.

    read the link below may help you out a little.

    https://support.native-instruments.com/hc/en-us/articles/4697682604049-Native-Access-2-FAQ

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert
    edited October 24

    I would write support that you can't install NA2.

  • Leon Mester
    Leon Mester Member Posts: 10 Newcomer
  • Leon Mester
    Leon Mester Member Posts: 10 Newcomer

    @lord-carlos

    yes, 11 e-mail exchanged since last week.

    And yet no solution...

  • Andy Lemaire
    Andy Lemaire Member Posts: 43 Member

    Just terrible to experience this. Are you on an Intel Mac or a M1/M2 Mac?

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert

    He is on Intel. You can see it on the last screenshot.

    But good questions.

    @Leon Mester did you download the Mac Intel version?

  • Leon Mester
    Leon Mester Member Posts: 10 Newcomer

    @lord-carlos yes sure Mac Intel, i even delete it and redownload/reinstall (on Native Support demand)

  • Andy Lemaire
    Andy Lemaire Member Posts: 43 Member

    The TP3 Mac Intel version was the next question. Just thinking out loud in order to get to a solution. 😀

  • Leon Mester
    Leon Mester Member Posts: 10 Newcomer
  • dariodelima
    dariodelima Member Posts: 43 Advisor
    edited October 25 Answer ✓

    Your problems will stem from Osx Catalina, X1Mk3 only works on Traktor 3.10 and sadly traktor 3.10 no longer runs on or supports Catalina OSX. So to install the latest Traktor 3.10 and use your X1 mk3 you need to update your osx, sadly. that goes for native access 2 also.

    Not sure what year your macbook is, if 2012 then sadly that also ends updates to osx at Catalina and you can not update to a newer OSX, if you have a newer macbook then you can update your osx and then you will be able to run Traktor 3.10, x1 mk3 and native access 2

    Hope that helps you find a solution, i was in the same boat had my 2012 macbook and it is still running good, but as the last osx to support that year of model mid 2012 was catalina, i had to upgrade and got a M1 pro in order to go with Traktor 3.10 and onwards. it was about time anyways to upgrade my laptop, 2012 gave me a good 10 years and not one issue or crash in all those years. 🙏

    there you can see Traktor 3.10 specifications. Supported on OSX 11 and upwards.

  • Leon Mester
    Leon Mester Member Posts: 10 Newcomer

    @dariodelima Interesting comment and link yes, thank you, but sorry to say, nowhere i can read/find my Mac won't be compatible.

    I've actually updated my OS to Catalina (for this purpose only) on both my Macbook (Air & Pro) here.

    From another point of view, on Native Instrument X1 selling page, the required recommended specifications are also listed again as "compatible". (Mac OS 10.15 or above...)

    Very confusing, because, from here customers will decide wether or not, if they are going to spend money into a new gear...



  • Leon Mester
    Leon Mester Member Posts: 10 Newcomer

    WORKING!!!

    To all, firstly thank you for taking time to respond and, for your suggestions.

    We did update OSX to Big Sur (technically not possible, but l managed to).

    Then installed Native Access 2, Updated also Traktor and BOOM the X1 is finally fully working.

    It was very confusing, when looking closer, Traktor 3.10 'required specs' are not matching with X1 mk3 'required specs'.

    Will now proceed test all the functions and new features on these.

    Again, BIG THANK YOU guys for your help, all the best. 🙏

Back To Top