Session Guitarist Picked Acoustic Plug-In Not Working Properly or Opening

Options
VocalxDrummer
VocalxDrummer Member Posts: 4 Newcomer

Hello NI users,

I'm having a bit of an issue using the Session Guitarist Picked Acoustic Plug-In that I just purchased from NI's website a few days ago. I'm fairly new to NI plug-in's, however, everything seems to be downloaded properly (I believe). I have Kontakt 7 installed as well as the Reaktor 6 plug-in's. (as it explains in the download that either of those can be used to open the Session Guitarist Acoustic plug-in using my DAW (which is Logic Pro X). The problem I am having, (and I hope this is an easy one). When I open Kontakt 7 in Logic Pro it loads the player and I can see the plug-in installed with a few others that I have in there. I can see the loaded previewed sounds on the right pane of the acoustic guitar, and when I go to click on the sound I want it tells me that that my version of Kontakt is too old and that I need to update to the newest version? I have the version downloaded that is compatible with my Mac OS, which is 10.15.7 (Catalina). I have tried other versions and even the latest version of Native Access, however, it will not allow me to download that to my OS. What do I need to do here, or is this plug-in even compatible with my Mac OS or what I am able to run? I tried contacting NI directly and have heard nothing back yet. Hopefully someone here can help me. Super frustrated here. Been wanting to record using this plug-in for several days now and nothing.


Attached are some screenshot of what I see on my end. Thanks for any help!!


Best Answer

  • VocalxDrummer
    VocalxDrummer Member Posts: 4 Newcomer
    Answer ✓
    Options

    Hi Jojo123,


    I just checked the download links for previous versions of Kontakt library plug-ins.

    I spotted the one that is giving me trouble:


    Is this the actual real plug-in or just a previous/older driver for the Session Guitarist Picked Acoustic plug-in?

    Asking for a few reasons, 1.) If I were to download this version, do I need to uninstall the previous version I have on my hard drive first? and 2.) if this is the actual older plug-in that will work with my 10.15.7 Mac OS, I already paid the $99 to download it on their website for the Session Guitarist plug-in. Should I request a refund from NI since it does not work with my current Mac OS? Thanks again for any help with this!

Answers

  • Jojo123
    Jojo123 Member Posts: 295 Pro
    Options

    Hello and welcome. Theres been a lot of issues with this. Have a look here.

    https://community.native-instruments.com/discussion/17039/previous-versions-of-recently-updated-kontakt-libraries-compatibility-with-k6-older-libraries

  • VocalxDrummer
    VocalxDrummer Member Posts: 4 Newcomer
    Options

    Thank you, Jojo123! Much appreciated. I'll touch base after I've installed the new hardware.

  • VocalxDrummer
    VocalxDrummer Member Posts: 4 Newcomer
    Answer ✓
    Options

    Hi Jojo123,


    I just checked the download links for previous versions of Kontakt library plug-ins.

    I spotted the one that is giving me trouble:


    Is this the actual real plug-in or just a previous/older driver for the Session Guitarist Picked Acoustic plug-in?

    Asking for a few reasons, 1.) If I were to download this version, do I need to uninstall the previous version I have on my hard drive first? and 2.) if this is the actual older plug-in that will work with my 10.15.7 Mac OS, I already paid the $99 to download it on their website for the Session Guitarist plug-in. Should I request a refund from NI since it does not work with my current Mac OS? Thanks again for any help with this!

  • Jojo123
    Jojo123 Member Posts: 295 Pro
    edited October 2023
    Options

    Hello, Im not sure that you dont have a compatibility issue here. I cant see your screenshots very clear. I dont know where Catalina support ends, but let me find some more links. Theres some documentation on NI site about compatibility.

    https://support.native-instruments.com/hc/en-us/articles/360014900358-Compatibility-of-Native-Instruments-Products-on-macOS

    This thread may be of interest.

    https://community.native-instruments.com/discussion/17247/rudiments-not-showing-up-in-kontakt-7-on-mac-os-10-15-catalina#latest

    I hope @Jeremy_NI can help out.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 10,619 mod
    Options

    This is the installer for the previous version of the library, it doesn't require the latest version of Kontakt so you can use it on your 10.15 Mac. Simply download the installer and install it.

  • VocalxDrummer
    VocalxDrummer Member Posts: 4 Newcomer
    Options

    Thank you Jojo123 and Jeremy_NI ! Much appreciated!

Back To Top