Hi, I have to upgrade my computer from mac OS 10.13 to 10.15 it get chrome updates otherwise some ap

repost
repost Member Posts: 10 Newcomer

Hi, I have to upgrade my computer from mac OS 10.13 to 10.15 it get chrome updates otherwise some apps will not work anymore.

Will my Traktor Kontroler S2 MK1 still be supported if i upgrade to 10.15 and if not what should i do

Tagged:
«1

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,009 Expert

    Are you sure it is S2 MK1? This is not listed even for 10.13

    You can check this compatibility article here:

    https://support.native-instruments.com/hc/en-us/articles/360014900358-Compatibility-of-Native-Instruments-Products-on-macOS

  • repost
    repost Member Posts: 10 Newcomer

    I'm pretty sure, it has the effects running across the top of the controller and if i google it it matches the image.That said ,looking at my device set up i see Traktor.Kontrol S2MK3.

    I have this Kontroler for more than 10 years and am not very bright when it comes to this kind of thing so appreciate your help a lot. Thanks

  • repost
    repost Member Posts: 10 Newcomer

    Sorry i meant Traktor.Kontrol S2MK2

  • LostInFoundation
    LostInFoundation Member Posts: 4,009 Expert

    If it says mk2 it should be a mk2.

    Which has been released EXACTLY 10 years ago, September 2013. So if you bought it “at” launchday, it could be.

    ‘And if it is a mk2, that’s why, as listed above, it is compatible with 10.13. And it will be compatible with 10.15

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,534 mod

    It sounds like you have MK1. The MK2 is still supported.

    Make sure you have Mojave installed for the MK1 version.

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,498 mod

    S2MK1

    S2MK2

    🦋

  • repost
    repost Member Posts: 10 Newcomer

    They look so similar but it's an MK2 which i have so it should be compatible with 10.15.what a relief.

    Thank you all for your help😊

  • repost
    repost Member Posts: 10 Newcomer

    Hi, one last question. Will the software program I'm using for the MK2 still be compatible with 10.15? Please advise.Thanks

  • repost
    repost Member Posts: 10 Newcomer

    I'm using the 2.11.3 17 version

  • LostInFoundation
    LostInFoundation Member Posts: 4,009 Expert

    Always from the same link:


  • repost
    repost Member Posts: 10 Newcomer

    So if the first supported version is 2.0.0 then 2.11.3 17 should be supported right?

    Sorry for my lack of understanding

  • LostInFoundation
    LostInFoundation Member Posts: 4,009 Expert

    If you use Traktor DJ2, yes

  • repost
    repost Member Posts: 10 Newcomer

    In use Traktor pro

  • repost
    repost Member Posts: 10 Newcomer

    I don't use Traktor DJ2, I use Traktor Pro and the program is 20.11.3 17 version but its still not clear to me if this will work with a 10.15 update.

  • c0nsul
    c0nsul Member Posts: 291 Pro

    Same link again:

    As Traktor PRO 2 is not listed anymore for 10.14 and 10.15 (and later versions), it seems 10.13 was the last macOS which officially supported Traktor PRO 2.

    Maybe you are able to install Traktor PRO 2 on Catalina, but chances are high that it won't work and that you have to buy the upgrade to Traktor Pro 3 (last supported version is 3.8).

Back To Top