Kontakt 7 - MIDI keyboard not recognized

Joshua Stamper
Joshua Stamper Member Posts: 7 Newcomer
edited August 2023 in Kontakt

Greetings, All,

I've searched through the forum and can't seem to find a solution to why my Arturia Keystep isn't being recognized in Kontakt 7 stand-alone mode or in my DAW (Logic), though it is recognized in my notation software (Dorico).

In the MIDI settings in stand-alone, it lists the Keystep, and I have it set to Port A. I've been careful to make sure individual instruments are also set to MIDI Port A. There is no sound. There is sound when I set the instrument to 'omni', but this less than ideal if I'm using more than one instance of Kontakt at a time, or when a single instance has more than one instrument.

Any help would be greatly appreciated!

Joshua Stamper

www.joshuastamper.com

Tagged:

Best Answers

Answers

  • MyStudioOne
    MyStudioOne Member Posts: 249 Pro

    Omni setting is listening to all midi channels coming from your keyboard and so one is obviously working. You failed to mention anything about midi channel setting in your post. Keyboard needs to be on midi channel one if kontakt is on one (single instrument load into Kontakt is midi 1 by default). Keyboard on 2 if a second instrument is added to Kontakt (now a multi). Kontakt uses the next midi channel (3,4,5...) for each instrument you add in the multi and you swap instruments on your keyboard by simply cycling through your midi channels on the keyboard.

    This may be too obvious, but I just wanted to make sure since you made no mention of midi settings. Cheers.

  • Joshua Stamper
    Joshua Stamper Member Posts: 7 Newcomer

    Thank you both for your help.

    @MyStudioOne : Yes - I neglected to mention that. The software instrument is set to port A, channel 1. In the Kontakt's main MIDI setting, I have the Keystep at Port A. I don't see any settings on the keyboard itself to set it to anything (though in the back, there's switches to set it to Internal, USB, MIDI, or Sync In).

    I went through all the channels, and found that it's coming in through Port A, channel 15 (weird). Not sure how to get Kontakt to recognize the Keystep at channel 1.

    Thank you for your insights and expertise!

  • MyStudioOne
    MyStudioOne Member Posts: 249 Pro
    Answer ✓

    I suspect that you can access such a setting in the Arturia Control Centre app. If you haven't installed it, here is a link

    Arturia - KeyStep Quick Start

  • Joshua Stamper
    Joshua Stamper Member Posts: 7 Newcomer

    That's such a help, @MyStudioOne. Thank you.

  • Sunborn
    Sunborn Member Posts: 2,179 Expert
    edited July 2023

    I went through all the channels, and found that it's coming in through Port A, channel 15 (weird).

    This is what i told you at first comment. It seems that your Arturia transmits Midi through channel 15.

    It should have (your Arturia) some kind of Settings somewhere, to change this.

  • Sunborn
    Sunborn Member Posts: 2,179 Expert
    edited July 2023 Answer ✓

    I found it, it is in the manual, page 13.

    You have to use the Shift button to access those settings.


  • Joshua Stamper
    Joshua Stamper Member Posts: 7 Newcomer

    @MyStudioOne : that absolutely did the trick. Thank you again!

  • Joshua Stamper
    Joshua Stamper Member Posts: 7 Newcomer

    Oh wow, @Sunborn, this is great to know about. Thank you!

Back To Top