Recording mixes issue since recent Traktor Pro 3 update?

Options
cbreener
cbreener Member Posts: 11 Member

Hello NI community. New to the forums, just figured I'd reach out to see if anyone has had the same issue that I'm experiencing. I recently updated to Traktor Pro 3.9.0, and now I'm having problems recording my mixes. I'm running macOS Ventura, Macbook M1, and a Pioneer DJM-850 soundcard. All my settings are exactly the same as they were before the update, it shows that I'm recording, and signals all seem fine. But when I'm done recording, there isn't a file created and in the "recordings" file within traktor. Can't find a file created anywhere. Just wondering if anyone else has experienced the same issues? Gone through all my settings, which seem to be set right, and my drivers are up to date with my DJM-850 as well. Everything was working fine before the update. Any help or insight on this would be greatly appreciated.

Thanks in advance!

Best Answer

  • lord-carlos
    lord-carlos Member Posts: 2,503 Expert
    Answer ✓
    Options

    Uhh, that sounds weird.

    Are you 100% sure you are at the correct directory?

    Try to copy the /Users/Chad... and paste that into finder or terminal.

Answers

  • [Deleted User]
    [Deleted User] Posts: 0 Newcomer
    edited July 2023
    Options
    The user and all related content has been deleted.
  • cbreener
    cbreener Member Posts: 11 Member
    Options

    Hi. Thanks for the reply. Yes, recording is activated. Using external, and in mix record settings its set to external also. Everything seems to set properly. It was working before the update, and the settings are the same as they were before the update as well. 3 x turntable set-up. (2 x CDjs & Tech 1200) Using channel A as my record channel. I'll post some pics of my settings....

  • cbreener
    cbreener Member Posts: 11 Member
    Options
  • cbreener
    cbreener Member Posts: 11 Member
    Options
  • lord-carlos
    lord-carlos Member Posts: 2,503 Expert
    Options

    When you play something you can see the input or record thing seeing a signal? If not, check this: https://support.native-instruments.com/hc/en-us/articles/360000471958-macOS-Dialog-App-Name-would-like-to-access-the-microphone-

    Otherwise everything looks correct.

  • cbreener
    cbreener Member Posts: 11 Member
    Options

    Hey lord-carlos, thanks for the reply. Microphone is activated and yes, signal is showing. Its very strange. The only problem I'm having is the actual recording isn't being generated into the recordings file. But I just noticed that in save file directory preferences, when choosing a file, my record attempts are showing there. But not in the actual recordings file. I'll attach those pics as well...

  • cbreener
    cbreener Member Posts: 11 Member
    Options

    Here are those pics...


  • lord-carlos
    lord-carlos Member Posts: 2,503 Expert
    Options

    my record attempts are showing there. But not in the actual recordings file.

    What do you mean?

    Are the files itself empty? Can you find them with the file thingy in mac (finder?) and open with a media player like VLC?

  • cbreener
    cbreener Member Posts: 11 Member
    Options

    Files can't be found anywhere on my mac. In the last pictures I posted, you can see the recording files I've tried recently listed there but they are greyed out because its in the window for choosing the file save location. But when I actually go to Traktor "recordings" file on my mac they are not there, or anywhere on my mac. Only my previous saved mixes are listed. And those mixes were done and saved before I did the last 3.9.0 update.

  • cbreener
    cbreener Member Posts: 11 Member
    Options

    ...sorry Traktor "Recordings" folder not file

  • lord-carlos
    lord-carlos Member Posts: 2,503 Expert
    Answer ✓
    Options

    Uhh, that sounds weird.

    Are you 100% sure you are at the correct directory?

    Try to copy the /Users/Chad... and paste that into finder or terminal.

  • cbreener
    cbreener Member Posts: 11 Member
    Options

    Yes, its the right directory. And I really appreciate your help with this lord-carlos. I've been a traktor scratch user since inception, and have never had any issues recording externally until now. I'll try what you suggested...

  • cbreener
    cbreener Member Posts: 11 Member
    Options

    Fixed. 😁 Appreciated all the input

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,870 mod
    Options
  • cbreener
    cbreener Member Posts: 11 Member
    Options

    For some reason the DJM-850 comes up twice in the external audio devices list - "Pioneer DJM-850(Core Audio)" & "DJM-850(Core Audio)". When I chose the other option (DJM-850(Core Audio)) and tried recording again, it worked fine, and created the mix file. Very strange. But glad its resolved.

Back To Top