Komplete Kontrol A61 - How to use all midi channels within Studio One DAW?

BrotherCharles
BrotherCharles Member Posts: 3 Sine
edited March 6 in Komplete Kontrol

I have created 15 additional midi templates within KK Midi control so that I can easily switch midi channels on-the-fly within DAWs. I named each template to correlate with the midi channel it is configured to communicate on: “MIDI CH 02”, “MIDI CH 03”, “MIDI CH 04”, and so forth. It was a rather monotonous, time-consuming task, but I finally got it done. Within most standalone VST apps, and various DAWs, I can easily select my midi channel templates and the Host will receive midi data correctly on whichever midi channel I desire.

Unfortunately, Studio One only seems to receive midi data on channel 1. No matter which template I select (using the preset buttons on the A61), Studio One & the A61 remain stuck on midi channel 1. Other DAWs such as: Samplitude Pro X (X4, X5, and X6), Reaper 6.x, Mixcraft 9, Cakewalk, and FLstudio 20.x all work with my midi templates just fine. It’s only Studio One (versions 3.x, 4.x and 5.x) that stays “stuck” on midi channel 1 when I use my A61. If I use one of my Arturia keyboards, Studio One cooperates with midi channel selections just fine. Mind you, the Arturia KeyLab boards have dedicated midi channel selection controls built-in.

This snafu is rather disappointing, and frustrating, for me - Studio One is my primary DAW. Is there anyone who can help me with this, please?

Tagged:

Comments

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw

    I Studio One, Go into Options -> External devices, double click the KK device (Midi) and in the Edit Device dialog, make sure that "All" midi channels are selected...

  • BrotherCharles
    BrotherCharles Member Posts: 3 Sine

    Thanks for taking the time to reply, Blindeddie, but that was one of the first things I checked. As a matter of fact, ALL midi channels are enabled for all external devices by default. You must not have understood what I tried to communicate in the OP. No matter what midi channel (by means of templates) that I select, my KK A61 seems to only be sending midi output on channel 1. This only happens within Studio One (versions 3.x, 4.x, and 5.x). All other DAWs and standalone hosts that I use get along just fine with my KK A61 and all midi channel (template) selections.

    My firmware is version 1.41

  • Blindeddie
    Blindeddie U.S.A.Member Posts: 824 Saw

    I attempted to recreate what you are saying is happening on S1 but any template I have (on my m32 which is just a mini-A series) uses the midi channel I have assigned in the Midi Assignment editor... can you post screenshots for your midi template Ch 2 (both Knobs and Keys Pages) I don't think the config is an issue based on the fact that it works with all other DAWS, but just curios. And the fact that it does work with all other DAWs, would make it a Studio One issue as the KB appears to be doing what it is supposed to in other DAWs.

  • BrotherCharles
    BrotherCharles Member Posts: 3 Sine
    edited March 4

    Hi BlindE,

    Yessir, I totally agree with you. I fully suspect that it is a PreSonus issue. The Midi channel transmission is working just fine in other hosts. I have triple checked all my 16 template assignments - all 32 knobs (8 knobs x 4 pages per template), keys, and pedal are correctly assigned to the requisite midi channels. I was hoping another KK A49/61 user, who also uses Studio One, would know the remedy (if there is a remedy).

Back To Top