Help with s4 mk3 eq knobs that won't calibrate

The knobs for my Mid's and high's are stuck in the extreme right and left positions as you can see from the screen shot. It's only happening on the C channel and I've tried everything I can think of. I've run the calibration numerous times, I had custom mappings and a midi fighter twister which I removed and restored all the settings back to the factory defaults. I've tried a fresh install of the software all together, but still stuck like this and it is a problem as I use all 4 decks when I play. Help me Obi-Wan Kenobi, you're my only hope.


Tagged:

Best Answer

  • DJ_DichOtomy
    DJ_DichOtomy Member Posts: 19 Member
    Answer ✓

    Well it is a hardware issue, mapped the eq to my midi twister and it works fine and since I'm only using 3 out of 4 banks on said twister, I have knobs to spare for remapping my eq. Now I just have to figure out how to turn off the knobs on the controller as if I turn one of those it immediately sends it to the extreme position. And I've been using this controller for so long and have so much muscle memory connected to it, I can see myself in the heat of the moment going for the knobs instead of the remapped ones on the midi fighter. Just when I thought I was done with midi mapping in traktor, back down the rabbit hole I go again. The further in you go, the bigger it gets.

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,277 Expert
    edited June 2023

    Did you also try reinstalling s4 drivers?

    Are they moving f you use mouse?

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,655 mod

    I'd try to remap the EQ High knob to some other control. That will tell if the hardware is causing the issue.

    Also, can you feel any resistance when you turn those problematic knobs? This does look like a hardware issue (knob being pushed in from the top).

  • DJ_DichOtomy
    DJ_DichOtomy Member Posts: 19 Member

    No I didn't try reinstalling the drivers, but that is a good idea and if I use the mouse I can turn them but as soon as I let go they snap back to the wrong spot again. The knobs feel normal with the right amount of resistance and the mid range one will actually move a little when I twist the knob but the high knob doesn't respond at all. I'll also try remapping the control, or i even have a mapping for this controller that works in mixx, I suppose I could check it out that way as well. Thanks for the suggestions, I'll investigate and post my results.

    You know, I just noticed the problem today and I was hoping by posting here, someone would be like "you need to do blah, blah, blah" and I'd be like "Oh yeah, duh. Why didn't I think of that." But I agree, seems like a hardware thing to me as well, I just don't want it to be a hardware thing. I find hardware issues to be very traumatic.😟 Okay, thanks for the suggestions I'll check it out.

  • DJ_DichOtomy
    DJ_DichOtomy Member Posts: 19 Member
    Answer ✓

    Well it is a hardware issue, mapped the eq to my midi twister and it works fine and since I'm only using 3 out of 4 banks on said twister, I have knobs to spare for remapping my eq. Now I just have to figure out how to turn off the knobs on the controller as if I turn one of those it immediately sends it to the extreme position. And I've been using this controller for so long and have so much muscle memory connected to it, I can see myself in the heat of the moment going for the knobs instead of the remapped ones on the midi fighter. Just when I thought I was done with midi mapping in traktor, back down the rabbit hole I go again. The further in you go, the bigger it gets.

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,655 mod

    Mapping EQ's to your Twister isn't going to prove the issue with the S4.

    Instead assing the problematic High Adjust Knob on your S4 to a channel fader command.

    Add In \ Mixer \ Volume Adjust

    Since you have other controllers in your setup, can you verify that the same issue happens with only the S4 mapping installed in the devices menu?

    Also, disable IAC or other similar drivers that may cause feedback loops.

Back To Top