Kontrol S8's screens flicker severely with Traktor 3.9.0

Hello!

I've just updated to Traktor 3.9.0, and I've noticed that both screens on my Kontrol S8 are now flickering quite severely - to the point where it becomes unusable.

The flicker only occurs when connected to Traktor - thus, not in MIDI mode nor while idle. Drivers seem to be OK, as I still get audio out of it.

My notebook supports OpenGL 4.6, so I assume that should be enough for requirements of the new version - "OpenGL Extensions Viewer" screenshot below:

Am I missing anything obvious here? Let me know if I can provide any further useful information.

Regards,

Martin

Tagged:
«1

Answers

  • Kubrak
    Kubrak Member Posts: 2,788 Expert

    Maybe trying latest graphic driver? If there is newer.

  • DoubleBpt
    DoubleBpt Member Posts: 7 Member

    i notice my system is lsame that yours this means defenely a bug... the cpu run like crazy.... the wost is i try everthiing to dowgrade stay even worst

  • Kubrak
    Kubrak Member Posts: 2,788 Expert

    Previous version should be installed on your computer and stored close to 3.9.

  • iyacyas
    iyacyas Member Posts: 3 Member

    I am having this same issue after updating to 3.9.0.. trying to update drivers etc on laptop but, not really seeing how the laptop graphics/drivers would cause issues on the S8 displays to flicker themselves... Did update the Radeon drivers etc.. no luck , still flickers on the 2 displays... ridiculous.


    @Kubrak - thanks for the downgrade pointer. going back to 3.8x does still work...

  • Kubrak
    Kubrak Member Posts: 2,788 Expert

     not really seeing how the laptop graphics/drivers would cause issues on the S8 displays to flicker themselves... 

    I am just guessing, but I think that rendering content of displays may be done using graphic card, so if something does not work well, it might affect controller displays.

  • martinbloedorn
    martinbloedorn Member Posts: 6 Member

    @Kubrak that was my theory as well.

    For now, I've downgraded to 3.8 - thanks for the pointer on that!

  • iyacyas
    iyacyas Member Posts: 3 Member

    So just for some more info, i have an older hp envy laptop on win 10 w intel cpu and intel iris graphics and is like 5+ years old. While slow to load. 3.9 works fine with the s8 displays, no flickering.

    could be something amd/radeon gpu related , but not sure. Have been trying various settings, windows compatibility mode , etc still nothing.

    given i own both a komplete s49 and maschine studio both w dual displays worried about future updates to those and frustrated because literally bought this new laptop 6 months ago specifically for running my ni setup

    sigh will keep poking.

  • iyacyas
    iyacyas Member Posts: 3 Member

    Have ticket 3955884 opened w NI. Will update if any progress

  • martinbloedorn
    martinbloedorn Member Posts: 6 Member

    Thanks, @iyacyas!

  • btong1
    btong1 Member Posts: 4 Member

    I have the same problem with 3.9 and a S4 MK3. Without Traktor no flickering, with Traktor 3.8 no flickering. It must be a problem in version 3.9

  • Alkaline
    Alkaline Member Posts: 4 Newcomer

    is there anything more specific on the subject? I got my S8 out after about 2 years to conjure up beautiful sets again and now the flickering on the displays.

  • Tellmeaboutit123
    Tellmeaboutit123 Member Posts: 493 Guru

    They changed the code, but as usual silence. Pretty bad really as quite a few are experiencing this issue.

  • Alkaline
    Alkaline Member Posts: 4 Newcomer

    The flickering is really annoying. I hope something happens as soon as possible, because I'm also looking for a new controller and I've always been very satisfied with Traktor and the controllers.

  • lord-carlos
    lord-carlos Member Posts: 2,320 Expert
    • Downgrade to 3.8
    • If you have a build in intel GPU that might also work.
Back To Top