An Audio Unit plug-in has reported a problem that could cause system instability.

Options
Dirk81
Dirk81 Member Posts: 6 Newcomer
edited May 2023 in Komplete Kontrol

Offenbar läuft Komplete Kontrol.component, 2.9.3r nicht auf meinem Mac Studio, OS13.4.

Sobald ich sie im Components Ordner habe, kommt die Fehlermeldung "Ein Audio Unit-Plug-in hat ein Problem gemeldet, das Systeminstabilität verursachen könnte. Beende Logic..."

Wenn ich sie dort entferne läuft Logic ganz normal.

Hat jemand eine Lösung dazu?

Besten Dank und Gruss, Dirk

Best Answer

  • Simchris
    Simchris Member Posts: 276 Pro
    Answer ✓
    Options

    Full disk access solved some issues for me. Native Access, for instance, downloaded 20 items no issue; then on next 10, ran into the disk access thing. Then after fix, works perfectly. Ran into same issue with some other software, both for music and other, with Ventura on M1 Ultra box. So, security is good, but wow, it's like setting up a Linux-based website now :)

Answers

  • LostInFoundation
    LostInFoundation Member Posts: 4,311 Expert
    Options

    Ich antworte auf English, weil das Forum “English only” ist

    What plugin are you talking about? Or it happens with many?

    I would try to make a plugins rescan in Logic.

  • Dirk81
    Dirk81 Member Posts: 6 Newcomer
    Options

    Hi LostInFoundation:

    As mentioned in my question, it is definitely "Komplete Kontrol.component, 2.9.3r" causing the issue.

    Thanks Dirk

  • Dirk81
    Dirk81 Member Posts: 6 Newcomer
    Options

    To be more specific: My problem is *not* to find the reason of the error message:

    Ein Audio Unit-Plug-in hat ein Problem gemeldet, das Systeminstabilität verursachen könnte. Beende Logic...

    or in English:

    "An Audio Unit plug-in reported a problem which might cause the system to become unstable. Please quit and restart Logic Pro"

    I need this plug in "Komplete Kontrol.component, 2.9.3r".

    On Native instruments website it is indicated as M1 compatible and also OSX 13.4*

    I need advice, how I can use further Komplete Control Plug in which is essential.

    I Supporte there is an bug with this version 2.9.3r, maybe with Mac Studio, because I updated last days and before the update it worked.

    I‘m considering to check Time Machine and re-install the *Version 2.8

    Thanks Dirk

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,879 mod
    Options

    This does seem to be cropping up more frequently- try the advice suggested here re full disk access if that doesn’t work deleting the Logic plist which will reset Logic settings (so back up any custom shortcuts)

    https://community.native-instruments.com/discussion/13598/kk-v-2-9-3-not-able-to-open-in-logic-anymore#latest

  • Dirk81
    Dirk81 Member Posts: 6 Newcomer
    Options

    Thanks, I will try this!

    Best Dirk

  • Simchris
    Simchris Member Posts: 276 Pro
    Answer ✓
    Options

    Full disk access solved some issues for me. Native Access, for instance, downloaded 20 items no issue; then on next 10, ran into the disk access thing. Then after fix, works perfectly. Ran into same issue with some other software, both for music and other, with Ventura on M1 Ultra box. So, security is good, but wow, it's like setting up a Linux-based website now :)

  • Dirk81
    Dirk81 Member Posts: 6 Newcomer
    Options

    Many thanks! I will check this

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,879 mod
    edited June 2023
    Options

    Did you try resetting Logic by deleting the Logic plist? That worked for the original posters who reported this issue (be aware it will reset the audio/midi settings and to back up any custom key switches first)

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,879 mod
    Options

    From this.

  • Dirk81
    Dirk81 Member Posts: 6 Newcomer
    Options

    I granted Full disk access, this didn't solve the problem.

    Then I removed Plist, exactly following this advice:


    problem solved by -

    Delete the Logic 10 preferences file AND the shared control surfaces file.

    In the Finder, choose Go > Go to Folder from the menu.

    Type ~/Library/Preferences in the "Go to the folder" field. (note: type exactly as written) ~/Library/Preferences

    Press the Go button.


    Remove the com.apple.logic10.plist file.

    Also delete the com.apple.logic.pro.cs file.


    After that, without restarting the machine, logic could open Komplete Kontrol.component, 2.9.3r.

    So my issue is solved.

    Thanks again to all that provided their help. All the best.

  • Kymeia
    Kymeia NKS User Library Mod Posts: 3,879 mod
    edited June 2023
    Options

    Ironically NI have just released an update that might have also fixed this but either way good news!

  • Jackboot
    Jackboot Member Posts: 1 Newcomer
    edited June 2023
    Options

    New update for Komplete Kontrol 2.9.4 did not fix it.

    Blank Logic project with just Komplete Kontrol plugin loaded - Logic stops working with message:

    An Audio Unit plug-in reported a problem which might cause the system to become unstable. Please quit and restart Logic Pro.

    As suggested above the fix is to delete the following files for your preference folder -

    Remove the com.apple.logic10.plist file. 

    Also delete the com.apple.logic.pro.cs file.

    That fixed Logic and got it working for me again

  • JESOUNDS
    JESOUNDS Member Posts: 11 Member
    Options

    Is this discussion dead? I still have this problem... For now I can use Komplete Kontrol in Logic Pro if I start logic in Rosetta, but that's not really a real solution.

  • beanradio
    beanradio Member Posts: 6 Member
    edited July 2023
    Options

    I had this issue and just fixed it by following the post from Kymela, delete the plist for logic 10 and logic legacy, reboot and try again. It should load without issue.

Back To Top