No signal coming through External media player to controller. S4 MK3

Dan Page
Dan Page Member Posts: 3 Newcomer

Hey team : ) 

I’ve got no signal coming through my live inputs on Traktor controller S4 MK3. I’ve plugged in two pioneer XDJ 700’s plugged channel’s C and D with the EXT button on. (Have tried different media players with same result. I brought a new computer. Mac m2, Tested the unit back at place of purchase (Rockshop digital KRd) works there. But not with my computer. I tried multiple input routing options and still no signal. Have been trying to sort for a while. Help would be greatly appreciated! Thanks in advance. Dan. Also here is a photo of audio saying not supported. 


Tagged:

Best Answers

Answers

  • lord-carlos
    lord-carlos Member Posts: 1,543 Expert
    Answer ✓

    Is traktor allowed to use the microphone? https://support.native-instruments.com/hc/en-us/articles/360000471958-macOS-Dialog-App-Name-would-like-to-access-the-microphone-

    If yes, can you show us a screenshot of the input routing tab?

  • Dan Page
    Dan Page Member Posts: 3 Newcomer

    Lord-Carlos thank you so much! Such a quick reply too. This has now been switched to microphone on and works great.

    What would you recommend I set my 4 channels to on input routing to in preferences? I’ll keep A and B internal and C and D for external.

    Also I have just realised I can’t get the external vinyl player signal. Comes through extremely quiet on C n D (no phono) channels but not at all on A n B that has phono?

    Thanks again in advance. Legendary help.

    Dan : )

  • lord-carlos
    lord-carlos Member Posts: 1,543 Expert
    Answer ✓

    On the hardware input, you have to connect your recordplayer to either A or B. Those two have pre-amps. And then active them, I think with Shift + EXT on the s4.

    You can then route input A or B to what deck you want in the settings. Input A does not have to go to Deck A.

    But even if you route input A to deck A, you can quickly disabling live input buy right click in the [A] in the traktor UI. This makes it easy to switch from internal playback to Vinyl / DVS.

  • Dan Page
    Dan Page Member Posts: 3 Newcomer

    Lord-Carlos thank you very much once again. This has worked perfectly. Made me very happy and solved a big problem for me as I’ve had to take two mixers to gig recently haha. If I could buy you a beer I would. Much appreciated!

  • lord-carlos
    lord-carlos Member Posts: 1,543 Expert

    Haha, no problem :) Glad my answer was useful.

    No beer needed, but if you want, you can klick on "Insightful" under my posts :P

Back To Top