Native Access installation hangs

DaveP Member Posts: 4 Newcomer
edited April 26 in Native Access

I am aghast at all the HORRID HOOPS suggested I go through in the SUPPORT help area for TRYING to install the latest Native Access 3.3.1 software on my 64 bit Windows 7 Pro. Native Access installation just HANGS with this BLACK BOX in the center of my computer screen, and EVEN HAS THE AUDACITY AFTER ABOUT 5 MINUTES TO TELL ME THAT IT IS TAKING A LONG TIME LOAD!

I didn't have NTKDaemon service installed on my PC, which WHY should that be a factor since the previous Native Access versions did not require it? And even AFTER installing it and verifying it was there, IT DID ABSOLUTELY NOTHING! The ONLY thing it changed was bring up a LOGIN dialog to the Native Instruments website.

What's wrong with NI, aren't their programmers smart enough to write code so an Installer doesn't NEED to make an active link to their website??? And how hard... is that to program anyway?? If you're logged in already, shouldn't be a problem! Good grief, just scrap the LOGIN requirement DURING the install, and make LOGIN a requirement when you USE the software, LIKE HOW 'NATIVE ACCESS' USED... WORK!


Best Answer


  • arachnaut
    arachnaut Member Posts: 75 Advisor

    When I first ran Native Access to upgrade to Komplete 14, things installed fairly fast.

    Later I ran Native Access for updates, and it updated itself along the way.

    It seems to me that the wait time has gone down from dozens of minutes or more to just a minute now.

    But I hear you about that wait time. I've been a long-time customer since Reaktor 3 came out and this current release of products is heavyweight in the extreme.

  • Miles
    Miles Member Posts: 1 Newcomer

    I feel I have to add my frustration to this as well. I currently re-installed Albion One to a drive that was wiped and have been prompted to install the latest version of Native Access 3.3.1. I concur that it seems a vicious circle, I have tried the NTK Daemon 1.11.0 setup after getting hung up on a "Installing Dependencies" issue only to have it hanging at Native Access Release 3.3.1

    I simply need a Kontakt player that is compatible with Spitfire Audio's Albion One. Until I can re register the serial # that is included in the software through Native Access, I cannot access the library in Albion One, rendering it completely useless.

    I really wish Spitfire Audio hadn't based their entire architecture on needing Kontakt player to function as it is currently dead in the water.

  • Rich_NI
    Rich_NI Customer Care Posts: 73 mod
    Answer ✓

    Hi @DaveP

    Native Access 2 is not compatible with Windows 7. It requires Windows 10 / 11 in order to run:

    Please use Native Access 1 instead:

    How to Downgrade Native Access 2 to Native Access 1

  • LostInFoundation
    LostInFoundation Member Posts: 1,709 Expert
    edited April 24

    My suggestion is to use Native Access 1 ANYWAY, no matter what os you are using. It works, while NA2 in many aspects don’t

  • Kymeia
    Kymeia Member Posts: 1,263 Guru
    edited April 25

    It doesn't though - I couldn't install Kontakt 7 and its libraries properly until I installed NA2 on my M1 system (at the time running Big Sur). I think for recent products on recent systems NA2 is the preferred option. On Mac it looks like there are still some issues around dependencies needing Rosetta 2 but I think most people should have that installed anyway as so much software for Mac is also going through such transitions (Metasynth for example has just finally gone Silicon ready last week but there is plenty that still is not).

  • LostInFoundation
    LostInFoundation Member Posts: 1,709 Expert

    You are right. For newest software it’s mandatory to use version 2. And they release not functioning versions of it anyway…

Back To Top