How can I mix externally in Traktor WITHOUT the headphone cue/vol being disabled/greyed out?!

djbrettb Member Posts: 6 Newcomer

This is incredibly frustrating.. I spent several hours installing and setting up Blackhole software to allow me to put Traktor Pro 3 into external mixing mode for the sole purpose of being able to separate the audio from each deck and record them separately in Ableton Live... After doing so I discovered that I cannot preview the tracks using the headphone cue and/or adjust the volume, it gets "greyed out"!!! This is absolute garbage NI. Traktor doesn't have any built in feature to send separate audio for each channel, and then even using a 3rd party software you designed it to RUIN THE WHOLE POINT OF WHY ANYONE WOULD WANT TO BE ABLE TO DJ WITH THEIR CONTROLLER BUT ROUTE AUDIO EXTERNALLY!!! WHY?!?!?!? I swithed over to Traktor when the S4 MK1 came out, stuck with it moving on the S4 MK2 and then MK3, have an F1 controller, long-time user but I am going to start looking into Serato and Rekordbox more too. Also, Serato has a VU mter feature that allows for you to adjust the track volume and it saves the meta data so you can make sure each track you adjust is a consistent volume. Flexible beat gridding too. But this?:

Note: When using the S3 and S4 MK3, these controls become "greyed out" as they are equipped with a cue monitoring section built into the devices. The S2 MK3 cue mix is controlled in the TRAKTOR software but the volume is controlled via the device itself.

This is so painfully stupid I can hardly stand it. Who would want to DJ without being able to hear the upcoming track in their headphones?!?!? Can you fix this idiotic setting and make it something optional, such as how you can enable EQ +gain, mixer FX, master volume control, autogain? Those are options you can enable/disable in external mixing mode. Headphone cue and volume NEEDS TO BE TOO. I am so fed up with Traktor right now. Please make this an option in your next update.


  • PK The DJ
    PK The DJ Member Posts: 393 Pro

    This is so painfully stupid

    There's a reason why the cue is greyed out when set to external mode - and that's because it's not required. If you're sending audio out individually from each deck, then you cue on the EXTERNAL device.

    In your case that would be Ableton Live.

  • djbrettb
    djbrettb Member Posts: 6 Newcomer
    edited April 8

    "and that's because it's not required"

    ...Right... however, I want to be able to use the S4 WITHOUT that feature being taken away, the way a DJ uses a DJ mixer and be able to preview tracks on it. I've never used Ableton for DJing stuff, but I'll have to figure out how to cue each channel in the headphones. I tried watching a couple of YouTube vids but haven't gotten it work so far. Also, unless I can midi map a controller for headphone cues on/off and a headphone volume knob it's going to be annoying as F*#! to have to do a bunch of little mouse clicks while I am trying to DJ. The whole point is to record each channel separately so I can make any minor edits to channel volume levels later, individually.

  • Kubrak
    Kubrak Member Posts: 2,049 Expert

    I guess, one technically cannot cue in Traktor, if mixing is done externally. You do not have the mixed sound in Traktor, for example. One could prelisten, but not prelisten in context of mix played....

  • LostInFoundation
    LostInFoundation Member Posts: 1,750 Expert

    You do have a cue on Ableton Live, and also a crossfader. If I recall correctly, they are midi mappable too

  • djbrettb
    djbrettb Member Posts: 6 Newcomer

    ^ Thanks, I have tried this I can't get audio form the headphones. Audio Ch. 1 "audio from" is "Ext. in" from Blackhole 1/2 (Traktor Deck A), Audio Ch. 2 "audio from" is "Ext. in" from Blackhole 3/4 (Traktor Deck B), and so forth for Traktor decks C and D... The "Audio to" I have tried setting to Master and tried Ext. out (both 1/2 and 3/4) and I can't ever hear any audio in my headphones regardless. I know about changing it from "solo" to "Cue" and messed with the volume knob in the bottom of the Master channel in Ableton, nothing seems to work. I have tried manually pulling the crossfader back and forth and it doesn't change audio playing out either. It seems like it's going to take a lot of time and trouble, and I don't have any guarantee I will get this to work. That is why I am so frustrated with NI for disabling the feature on the S4 controller, it shouldn't have to be this difficult. Simply allowing the controller to have all the same functionality as when using it in internal mixing mode would have had this working like a dream, but here I am spending hour after hour searching for a solution, trial and error, no fix for the problem.

  • djbrettb
    djbrettb Member Posts: 6 Newcomer

    Anyone running Blackhole to route audio into Ableton? There was another option to route audio called Jack, but it's not compatible with my setup. M1 Macbook Pro running OSX Ventura, Traktor Pro 3.8.0, Traktor S4 MK3, Blackhole, Ableton Live 10.1.43

  • djbrettb
    djbrettb Member Posts: 6 Newcomer

    Native Instruments: Is there any technical reason that what I am asking for is NOT possible??? I can adjust everything else that I need to on the S4 controller... literally EVERYTHING ELSE but THIS!!!! Why must you make this so needlessly complicated?!?! Too much work for you? Traktor has been neglected for years... yet I have stuck with them, over and over again. Can anyone from NI chime in here?

  • 6xes
    6xes Member Posts: 263 Pro
    edited May 10

    i have been running black hole on the m1 ventura...

    im guessing here... but on the outputs within Ableton...they would be 1/2 3/4 and 5/6

    in which case you would route anything you want to send to your speakers to 1/2 and every other blackhole gets sent to 3/4 or 5/6where you would have your headphones plugged into in the back of your interface... alternatively you could swap the outs of 3/4 to be the master... so that 1/2 become headphones as normally the headphones on the front of your audio interface are tied to 1/2 anyway

    this solely depends on your interface... and whether you can route the sound from within the interface


    you would then create x4 toggles( midi buttons) to swap your blackhole stereo pairs A B C D redirecting them to 1/2 as required and your cues to 3/4

    So basically you need to create the routing within Ableton... as Pk the Dj mentioned

    you are essentially dealing with sends & hardware outs


  • Quade
    Quade Member Posts: 103 Helper

    Try Wasapi Exclusive mode from your audio drop down menu, the main audio is adjustable but I don't think it will assist with headphone audio, NI is very clever lately to ensure users experience the worst.

    I just used my Traktor Kontrol S3 for the 1st time again in like 2 or 3 months & I have been experiencing this grey'd out issue on the software.

    It's definitely not hardware related I can honestly guarantee you, it's the software. They have in a manner enforced when hardware gets connected, the on board software controls gets removed so users are limited to their uses.

    Sorry about that but happy testing.

  • djbrettb
    djbrettb Member Posts: 6 Newcomer

    Thank you 6exes and Quade-

    to 6exes: I will look into this and give an update.. it does make sense to route things a particular way within Ableton. Basically toggling sound to headphones and sound to speakers… it might work, I’ll trouble shoot it. I am literally plugging headphones into my laptop if I’m routing through Ableton, no external device between my DJ mixer and the laptop. The main problem when using blackhole is that although I get to send each channel from my Traktor S4 controller as separate audio channels to Ableton it doesn’t allow me to additionally send a dedicated Master or Booth out signal… if so, I could route that directly to the speakers, record my audio channels separately in Ableton, deal with how to hear the headphones audio…

    and Quade:

    You are right! The greyed-out section is the complete problem I am trying to work around. If NI would simply NOT disable the headphone cue audio when using external mixing mode we could simply use the mixer as usual and still be able to route each deck separately into Ableton for recording and then from Ableton output the audio back to the S4 to send audio through the speakers. It’s the ability the separately record the DJ mixer channels that I want, but trying to use Ableton like a DJ controller, all the weird routing required to hopefully even make this possible, is the needlessly complicated mess about the whole thing. NI SHOULD NOT disable/grey out this feature. Absolutely has me irate… and furthermore they should incorporate virtual output routing to send booth to booth, master to master like regular DJing *PLUS simultaneously be able to output individual decks into separate audio channels in a DAW, all without losing ANY functionality of the mixer/DJ controller.

    I hope you folks at NI are reading this. Even when using a third-party application like blackhole your company STILL sabotages things. I want my DJ controller to do everything it’s capable of REGARDLESS of whether I route audio to a DAW or speakers. Why can’t it do that?!?! Why can’t it do BOTH of those things?!?!

Back To Top