Why is my Maschine Plus library reset every now and then?

2

Answers

  • badaz
    badaz Member Posts: 36 Member

    After restart, try to go to settings > library and hit rescan

  • badaz
    badaz Member Posts: 36 Member

    I've not measured it, I seem to remember something around 30mo/s does this sound plausible? I believe it also depends on the type of connection / SD card reader used. I was just a little disappointed as I was expecting to witness a visible leap in transfer speeds and it still felt a bit slow. I've read the same thing as you about the Samsung Evo plus being similar in speed though

  • LostInFoundation
    LostInFoundation Member Posts: 3,971 Expert

    I mean the speeds they are advertising (which in any case should be the maximum), not to measure it.

    20 seems very low (belonging to cards from many years ago)

    My own, which is at least 5 or 6 years old, says 95 read and 20 write


  • badaz
    badaz Member Posts: 36 Member
    edited April 2023

    This is the one https://www.samsung.com/us/computing/memory-storage/memory-cards/evo-select-adapter-microsdxc-256gb-mb-me256ka-am/

    They say read speed up to 130MB/s no spec provided for write speed (except "slower than read" ^^)

  • Rototo85
    Rototo85 Member Posts: 17 Member
    edited April 2023

    I m not sure the problem Come from the sd card because i ve got a good sd card i think and we got the same problem in the same Time look like a bug

  • badaz
    badaz Member Posts: 36 Member
    edited April 2023

    Ok, it seems I'm not the only one having this bug, therefore the next question is: on which version of the system did this bug start appearing. It seems to me I had not encountered it prior to 1.4.5.2, has any of you had this bug on previous versions?

  • Rototo85
    Rototo85 Member Posts: 17 Member

    Not me juste this one

  • D-One
    D-One Moderator Posts: 2,689 mod
    edited April 2023

    @badaz asked.

    About the microSD card I use: I specifically bought it for the Maschine +, so it is not the stock one, it is a Samsung Evo Select microSDXC UHS-I U3 A2 V30. It is supposed to be faster but I did not really notice any difference when copying my files to it, so maybe it is still not fast enough? Do I need a V60? a V90?

    V30 is uber slow... But technically you dont need a faster one unless you want it to be faster.

    For the USB2 speeds of the M+ a 60 MB/s is as high as it can handle as it's the limit of USB2 afaik. Getting a faster one will only help when using it in the computer to transfer stuff if you have a fast reader or USB3 reader, i use a 90MB/s one... night and day difference.

    I would also avoid using those uber tiny card meant for phones that have to use an adapter, they are more fragile and the adapter is just an added point of failure with no benefits that i can think of.

    Note i am not saying this lib issue is caused by the SD, but i wouldn't be surprised, SD cards can be finicky, other devices such as photo/video cameras often have an official list of compatible or recommended cards.

    I strongly recommend Sandisk Extreme Pros, propper size, I cant even find anything slower than 170 MB/s nowadays.


  • badaz
    badaz Member Posts: 36 Member

    As I understand it, V30 only says something about the guarrantied minimum write speed. I had not thought that the adapter might be a problem, but I guess you're right, it's just another SPOF (single point of failure). I'm going to try another adapter first, then if nothing changes I'll check if I have a classic SD

  • badaz
    badaz Member Posts: 36 Member
    edited April 2023

    Ok, I just tried using another adapter, started the Maschine, white pads, library was reset. I then realized that when I go to settings / library right screen, it displays message "no sdcard". If I remove the SDCard then push it inside the slot again and keep the pressure on it so that it is farther inside the slot, it then displays the size of the sdcard. Howerver, some seconds after I release the pressure, it says "no sdcard" again, although sdcard is "in place" and maintained by whatever mechanism is used to keep it in place. I hope this is not a hardware defect of the Maschine itself. However people here seem to be experiencing the same problem since last update only, which gives me hope.

  • LostInFoundation
    LostInFoundation Member Posts: 3,971 Expert

    By “For the USB2 speeds of the M+ a 60 MB/s is as high as it can handle” you mean writing or reading speed?

  • D-One
    D-One Moderator Posts: 2,689 mod
    edited April 2023

    Yes, it's V for "Video Speed" or something silly like that, a stupid solution so that people could know the card could handle their 4k cameras but it just made things more confusing. I would ignore the "V" silliness and only mind the actual advertised speed, that's what matters.

    SD cards naming schemes and symbols are a complete mess, cards have more decoration than a 12yr gaming desktop... it's worst than USB 3 names: https://www.youtube.com/watch?v=Bw89C41NY7U


    Both, it's just the max it can handle... max speed of USB-2 is technically 480 Mbps which is 60 MB/s, under most scenarios, it should be actually around 50 MB/s I think. The quality what you're using whether it's an SD card, external drive or whatever else matters, things like the controller chip and whatnot.

    From my experience read and write for this stuff is usually pretty much the same (at least from reputable brands) my SD says 90 MB/s and it hits it's mark with only a -9 MB/s difference for the read (on a USB3 card reader).

    On the M+ it will be slower due to the USB-2 bottleneck.


  • D-One
    D-One Moderator Posts: 2,689 mod

    Dang... that doesn't sound good 😬

    If it consistently works or stops working by applying or releasing pressure then I'd say the only logical conclusion is that it's a physical HW problem and not a software one. Could be the locking mechanism or bad contacts.

    Do you hear an audible click when you push the card in?

  • ozon
    ozon Member Posts: 1,228 Expert
    edited April 2023

    Putting physical pressure on hardware is very very rarely related to software failures (unless we’re talking about pressure measurements).

    IMO this is a hardware failure. Either within the SD card, the card adapter, the SD card reader or even the Maschine main board.

  • badaz
    badaz Member Posts: 36 Member

    Yes I hear the click, and you know, when it clicks and you let go off it, there is a slight recoil from the position it is at when you push it all the way in. So when I say "applying pressure", I mean keeping it in that position, after the audible click, but before releasing it so that it remains locked in place.

Back To Top