Logic pro X says "Module manquant pour l’appareil « KOMPLETE KONTROL S-Series ».

Tche
Tche Member Posts: 2 Newcomer

Hi, I'm running Logic pro X 10.6.2 in Rosetta mode, in French and when I start Logic Pro, it says "Module manquant pour l’appareil « KOMPLETE KONTROL S-Series ». I tried to reinstall, but the message still appears. Could you help me ?

Best Answer

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    edited March 2023 Answer ✓

    Hey @Tche What is your operating system? If you have a M1 computer it's probably one of the newer OS, why do you use an old version of Logic?

    Check that the keyboard is fully functional in Komplete Kontrol in standalone.

    Install the latest Komplete Kontrol update. Reinstall if needed.

    Check that Komplete Kontrol and Logic both have Full Disk Access: How to Enable Full Disk Access on macOS

    Additionally you can close Logic and delete the file responsible for control surfaces found here:

    MacHD/Users/UserName/Library/Preferences/com.apple.logic.pro.cs

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    If that doesn't fix the issue, can you share a screenshot of the error message?

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,918 mod
    edited March 2023 Answer ✓

    Hey @Tche What is your operating system? If you have a M1 computer it's probably one of the newer OS, why do you use an old version of Logic?

    Check that the keyboard is fully functional in Komplete Kontrol in standalone.

    Install the latest Komplete Kontrol update. Reinstall if needed.

    Check that Komplete Kontrol and Logic both have Full Disk Access: How to Enable Full Disk Access on macOS

    Additionally you can close Logic and delete the file responsible for control surfaces found here:

    MacHD/Users/UserName/Library/Preferences/com.apple.logic.pro.cs

    Note: the User Library folder is hidden. To access it, click on Go in the menu bar and press down the Alt key. You'll now find the Library entry in the menu:

    If that doesn't fix the issue, can you share a screenshot of the error message?

  • Tche
    Tche Member Posts: 2 Newcomer

    Hi Jeremy, I run with Ventura 13.2.1.

    I did all you mentioned : download the latest Logic Pro X version and delete the file for control surface. It fixed all. Many thanks ;-)

Back To Top