Phase use with traktor pro 3

Chris1501
Chris1501 Member Posts: 9 Newcomer

can anyone help me please as I have lost my mind trying to set phase up with traktor. I have an Allen and heath xone 23c mixer and obviously this is supported by traktor but my main issue is trying to get phase to work with traktor. It doesn’t matter what I do I cannot seem to get both channels playing and another issue I have is both channels will play on the same deck for some reason instead of separate ones. I also seem to have an issue where the fader for say channel a is instead set for b. Basically it’s all over the place I am ready to get rid of the lot and just continue with traditional vinyl. Could anyone send me screen shots of how they have DVS set up or even better phase settings in the traktor set up? Thanks

Answers

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert
    edited March 23

    Did you do the xone 23c DVS mod? Should be in the manual on how to do it.

    You need to do it, otherwise the xone will send .. master or something over USB, but you want the raw inputs.

    (I'm not super into phase, I just assume you connect it to the mixers input. If it's software based I don't)

  • Chris1501
    Chris1501 Member Posts: 9 Newcomer

    The mod for DVS has been done.

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert

    Traktor is in external mixing mode?

    Can you share a screenshot your audio and routing settings please?

  • Chris1501
    Chris1501 Member Posts: 9 Newcomer

    I will post some later as currently not home to do so. Can you possibly give me screenshots of how it should be set up?

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert

    Sure. See this guide: https://support.native-instruments.com/hc/en-us/articles/360000509157-TRAKTOR-PRO-3-Timecode-Setup-Guide

    Ignore the first setup part. But see Input configuration and output configuration (external mixing mode)

    And make sure external mixing mode is selected.

    Ignore the Internal mixing mode.

  • Chris1501
    Chris1501 Member Posts: 9 Newcomer

    Will let you know how I get on and thanks for your help.

  • Chris1501
    Chris1501 Member Posts: 9 Newcomer

    This is how it’s set up on configuration. Again nothing works.

  • lord-carlos
    lord-carlos Member Posts: 1,555 Expert

    Well yeah, it seems you connected input channel 2 and 3 to both input decks. And than also channel 2 and 3 to output on those decks.

    You probably want input on deck A to be "in 1" and "in 2"

    And output on deck A to be "out 1" and "out 2"

    Keep deck b as is.

  • Chris1501
    Chris1501 Member Posts: 9 Newcomer

    Cheers will give it a whirl in a bit and let you know.

  • Chris1501
    Chris1501 Member Posts: 9 Newcomer

    I did what you said but now I have another issue. Basically when playing time code the pitch keeps resetting to its slowest setting and then I have to recalibrate every time I choose another track.

    Any idea? Also would you know setting for line inputs so I can get the phase to work?

Back To Top