How to get larger screen from Kontakt in PreSonus Studio One

mgourley
mgourley Member Posts: 4 Newcomer
edited January 2022 in Kontakt

Having a hard time finding tutorials on some of the basics. Brand new to Native Instruments (have Komplete 13) and still a baby in Studio One 5.

Kontakt opens fine as a stand alone and I have the option of screen size changes. But when I open it in Studio One the screen is so small you can barely read anything. There is a drag down in the bottom right corner which will drag down a little. But I can find nothing to make the screen bigger. Can't find anything on this so any help is greatly appreciated. Thanks

Best Answer

  • mgourley
    mgourley Member Posts: 4 Newcomer
    Answer ✓

    Hey guys, I appreciate all the help. Very strange... I did the disabling of the high DPI mode which then made the screen huge. Long story short, I went back and forth with this a few times over a couple days plus some rebooting the computer. Not sure what happened but all of a sudden the screen is manageable. I don't know why it suddenly started functioning, but it did and that is all that matters.

Answers

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod

    Hey mgourley, I assume you have a High dpi monitor (or 4k), unfortunately Kontakt is not yet scalable for this kind of monitors when inside a DAW. There should be a setting in Studio 5 to enable/disable high dpi mode:

    I hope that helps!

  • mgourley
    mgourley Member Posts: 4 Newcomer

    Thank you Jeremy. Yes and No for a solution. It did change it so it opens bigger, but now it is so big that I can't get to the corners to change size or move it up or down. Not sure what to do about it. Guess I will do some more research this weekend. I was a bit dismayed that Native Instruments only had this forum for support. I found no email or phone number with which to contact them directly. I do appreciate your help though.

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod
    edited January 2022

    Hey mgourley, we do have a dedicated support section, you can see it on top of the page, next to Community ☝️

    This community is a good place to ask for help but we still have all our teams available via email. Here's a video on how to get support if you prefer going that route:



  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 7,131 mod
    Regarding the scaling of the Kontakt plug-in, unfortunately like most of our plug-ins high dpi scaling is not yet supported. Maybe some of our users have workarounds ?
  • wrongtools
    wrongtools Member Posts: 1 Newcomer
    We actually have a simple resizing option implemented in our instruments. Hope other sample developers will implement this in the future as well. It is fairly easy to build into the KONTAKT code. 

    https://youtu.be/A9PSaISeyxY

    https://wrongtools.com

  • mgourley
    mgourley Member Posts: 4 Newcomer
    Answer ✓

    Hey guys, I appreciate all the help. Very strange... I did the disabling of the high DPI mode which then made the screen huge. Long story short, I went back and forth with this a few times over a couple days plus some rebooting the computer. Not sure what happened but all of a sudden the screen is manageable. I don't know why it suddenly started functioning, but it did and that is all that matters.

  • EvilDragon
    EvilDragon Moderator Posts: 947 mod

    You can actually reset Kontakt's GUI size if you click the Options button in top header (looks like a cogwheel), then on Interface tab you have Reset Size button. Click it!

  • SH-1
    SH-1 Member Posts: 23 Helper

    It was only a matter of time until this popped back up :)

    If you let Studio One be scaled by windows (right click the .exe or your shortcut and go to Hi-DPI settings, then choose "windows" instead of "application"), Kontakt (and all other non-DPI aware plugins) will be the right size.

    However this makes your whole DAW blurry- Not an ideal solution. But it's very likely to be the best one available if your DAW has a proper Hi-DPI mode.

  • mgourley
    mgourley Member Posts: 4 Newcomer

    Thanks for the additional advice. EvilDragon I do see that. Thanks. At the moment it is working fine so I won't fool with it further and mess it up lol! SH-1 I am really surprised there is not more out there on this other than the fact that it has been an issue for a lot of people. Hopefully in the future there will be better and easier controls. I notice too that my Nektar Impact faders work great with Studio One apps but not the Native Instruments or other 3rd party VST's. Not sure if there is a fix for that, but right now I am just trying to learn the basics. I appreciate all the feedback as I am somewhat new to all this.

Back To Top