Welcome to the new and improved Native Instruments online community. Join our active forum of 40,000+ members for discussions and much more.

Version 3.6.2 compatible to my Mac Book Pro

Is the newest Traktor Pro 3 Version (3.6.2) compatible to my Mac Book Pro (Mid 2014)?

MacBook Pro (Retina 15", Mid 2014)

2,2 GHz Intel Core i7

16 GB 1600 MHz DDR3

macOS 10.14.6 Mojave


I don't wanna upgrade my macOS because it is a smooth running system :-P

Best Answers

  • Mark_NI
    Mark_NI Customer Care Posts: 190 mod
    Answer ✓

    Hi @djtimd,

    yes, 3.6.2 is compatible with macOS 10.14. Up to version 3.7.1, you can update Traktor - that's the last one supported on Mojave.

  • Mark_NI
    Mark_NI Customer Care Posts: 190 mod
    Answer ✓

    3.7.1 - but not for too long, the 3.8.0 beta test is over and the release is expected to take place soon.

Answers

  • Mark_NI
    Mark_NI Customer Care Posts: 190 mod
    Answer ✓

    Hi @djtimd,

    yes, 3.6.2 is compatible with macOS 10.14. Up to version 3.7.1, you can update Traktor - that's the last one supported on Mojave.

  • djtimd
    djtimd Member Posts: 2 Noise

    Which One ist the latest Version?

  • Mark_NI
    Mark_NI Customer Care Posts: 190 mod
    Answer ✓

    3.7.1 - but not for too long, the 3.8.0 beta test is over and the release is expected to take place soon.

Back To Top