direct thru option on traktor kontrol s4 mk3

Options
ILIAS
ILIAS Member Posts: 13 Member
edited February 2023 in Traktor Software & Hardware

hello does anyone knows how to enable the direct thru option on traktot kontrol s4 mke ? Iam using the latest version of traktor pro 3. thanks!


Tagged:
«1

Answers

  • Kaiwan_NI
    Kaiwan_NI Administrator Posts: 2,646 admin
    Options

    Hi @ILIAS Usually clicking on the EXT button should activate the direct thru. I see you've been in touch with our support team already. Please keep us updated how you get on.

  • ILIAS
    ILIAS Member Posts: 13 Member
    Options

    hi again and thanks for the answer. why in the program doesn't show it? the exit button is the same as the direct trhu option?

  • Sûlherokhh
    Sûlherokhh Member, Traktor Mapping Mod Posts: 1,946 mod
    Options

    It is my understanding that 'Live Input' and 'Direct-Thru' are the same thing in Traktor. Am i wrong?

  • ILIAS
    ILIAS Member Posts: 13 Member
    Options

    so why are two different options?

  • PZZO
    PZZO Member Posts: 18 Helper
    Options

    Direct thru and Live input are different things.

    Direct thru is a sound card setting. On some hardware (like the Audio 6), the channels have both a line in and a line out. Turning on direct thru tells the soundcard to pass the line in signal directly to the line out in hardware, and skip all the software.

    Live input is a deck setting which says to play the input into a traktor deck. Unlike direct thru, it gets routed through all the mixing in the traktor software (eqs, fx, filters, gain, etc.)

    If you're using a Kontrol S4 - assuming you're not trying to do some crazy audio routing - you probably don't need direct thru because the controller expects all the mixing to happen inside the traktor software.

    What you're probably looking to do is set a deck to Live Input to route an input into Traktor - based on the screenshot, it looks like that's already set up 👍

  • ILIAS
    ILIAS Member Posts: 13 Member
    Options

    thanks you for the detailed answer but still i can't understand why when i use the live input option for a microphone that is connected i realize a slightly delay (not only me and the singers that listening to their voice) How can i fix it or skip it?

  • PZZO
    PZZO Member Posts: 18 Helper
    edited April 2023
    Options

    Just the nature of doing mixing in software, you're going to get some latency - but it shouldn't be distracting. Here's a few things you could dig into:

    • What are the specs of your computer? There is some latency introduced by Traktor - it shouldn't be a lot, but if your computer isn't fast then it could be significant. Enabling multi-core processing might help with this if you don't have it turned on already.
    • What is your audio settings like? Under audio setup, what is your overall latency? It shouldn't be too high where you notice a delay (probably like low tens of milliseconds - mine's at 15ms) but not too low that your sounds starts to glitch.

    If all else fails, you could "skip" it with hardware if you're trying to synchronize with other live performers. Even just a small mixing console to route your Kontrol S4 master output + the other live instruments would do the trick. Because it's analog you get no latency, proper monitoring, less hiccups from software, and it might even sound better too (mixers usually have better pre-amps than DJ controllers).

  • ILIAS
    ILIAS Member Posts: 13 Member
    Options

    my pc specs are good enough ...

    dell windows 10 64 bit

    Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz  2.59 GHz

    RAM   32,0 GB

    with an external graphics card nvidia ge force GTX 1660

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,769 mod
    edited April 2023
    Options

    The S4 Mk3 doesn't offer Direct Thru option like S8 or Z2 does. Usually it is controllers with TRAKTOR LOGO button in the mixer section that does this. Use the Live inputs instead.

  • ILIAS
    ILIAS Member Posts: 13 Member
    Options

    I think the better way to do it by turning off the software program and use it as a stand alone mixer...

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,769 mod
    Options

    I'd first try optimizing windows. It sounds like it is dj and gaming machine.

  • ILIAS
    ILIAS Member Posts: 13 Member
    Options

    Yes it is a gaming laptop https://www.dell.com/support/manuals/el-gr/g-series-15-3590-laptop/dell-g3-3590-setup-and-specifications/dimensions-and-weight?guid=guid-7df32f47-45cf-4a08-ad99-b01eec4f3ce6&lang=en-us

    What do you mean optimizing windows... i have done all the nesasury settings to work my pc only for playing music ... i don't play any games. The only setting i haven't done is about the praphic card... and i would need some help there...

  • Stevan
    Stevan Traktor Mapping Mod Posts: 1,769 mod
    Options

    The Dell Support assistant is what caused issue for most Djs. Have that disabled first and then go troug all tips from the following article.

    https://support.native-instruments.com/hc/en-us/articles/209571729-Windows-Tuning-Tips-for-Audio-Processing

  • lord-carlos
    lord-carlos Member Posts: 2,592 Expert
    Options

    I think even with optimizations live input will have a slight delay.

  • J. Spencer
    J. Spencer Member Posts: 17 Member
    Options

    The microphone delay is horrible, no matter how low I kick the latency. I ultimately switched to having a Mackie 402VLZ4 (802 if I need more control over mic eq) and running it external. The primary downside is that I no longer can record the mic input as part of my set recording, but the vocal audio is so much cleaner.

    On a side note, the S4MK3 isn't nearly as bad as the Pioneer DDJ-800 - which only offers two settings for the mic input latency. Both are very noticeable and distracting when trying to deliver any kind of speech.

Back To Top