Is there a way to switch focus from Maschine Plus to KK S88 in the same instance of Maschine 2?

Tiny Rivers
Tiny Rivers Member Posts: 9 Sine
edited March 6 in Maschine

I'm on a brand new Mac Pro (Big Sur OS), all my software is up to date. Using HDX Pro Tools Ultimate. I'm trying to use my Maschine Plus to lay down drums in Maschine Plug-in. After that, I would like to switch to the next scene/group in the same instance of Maschine and lay down piano sounds etc with my KK S88.

Is there a way to switch focus from one device to the other in the same instance of maschine? I've gone to the controller part of maschine menu and it shows both devices checked, (they also show as active in Pro Tools MIDI Preferences). the instruments show up on both device screens, but only Maschine Plus will play anything. (sometimes the other way around. It's obviously confused on what is controlling it.) The S88 shows the instrument is loaded and keys change color, but no sound. Also the instrument CAN still be heard on the Maschine plus pads. I dont need them there though, I need to play them on the S88. of I browse the sounds on the s88, I can hear the previews just fine.

When I go to hardware under Maschine Preferences, it's either set on Maschine Plus, or blank and if I bring up S88 in Maschine Preferences, there are no options in the menu at all. It's just a blank screen with a close button.

Do I possibly need to put s88 in MIDI mode and have it just be a dummy keyboard controller, and let Machine plus do the browsing? It seems like this might be the answer, but I can't find anything that's written basic enough for me to understand how to set the S88 up like that.

I have read a lot of things but I can't find anything that is step by step, on how to do this....(or if it's even what I need to do to make it happen.)

If anyone has any ideas, please let me know. I don't need the S88 to be in control of browsing or any of that, I just need it to play the piano/key/bass sounds, and be able to switch between Maschine Plus and s88 in the same instance of the Maschine Plug-in.

I'm a 20 year experienced pro tools user for traditional recording, but I've only recently been trying to work with MIDI. I'm having trouble finding anything basic enough to explain how the CC assignments work. Thanks for your patience.

…and lastly, is this integration of the 2 devices simply not possible, and does that mean I always have to have one of them completely disconnected? Will I then need to restart protools if I want to use the other controller?

Best Answer

  • Tiny Rivers
    Tiny Rivers Member Posts: 9 Sine
    Answer ✓

    Ok sooooooo….

    I have made it work!

    a few things… I’m used to the input/outputs that I have to deal with being the ones at the bottom of the track in the mix window. Things are different with this MIDI stuff. Forgive me for not knowing my way around all this yet. I’m just now getting into this MIDI stuff after 20 years of not messing with it!

    1. I had to toggle the MIDI OUTPUT SELECTOR at the top of the track in edit window to Maschine 2 MIDI Channel 1. (Appears that any of those channels will work at this point.)
    2. Arm track to Record. The Maschine Plus doesn’t care, but the KK88 needs the track armed for you to be able yo hear it.
    3. If the KK88 is not responding still, put the Maschine Plus in MIDI Mode (I had been trying to put the K88 in midi all this time.) Now you can uncheck Maschine Plus in the controller menu in Maschine. This should hand the controls back over to the KK88.
    4. Also when going into Maschine preferences, under “hardware,” KKS88 is still blank with no options, but I’ve found that if I select it, it sometimes kicks this all into place.
    5. As far as keeping all these things assigned to either KK88 or to Maschine Plus seems to work, but they also both seem to work sometimes without switching it over at all

    Like I said, I’m not sure what exactly I’ve done, but I DO know that I’ve got it working thru trial and error! So if this helps anybody….there ya go! If anyone knows exactly why this is working, feel free to fill us in. Mostly, it just seems like it was a matter of figuring out a way to keep the 2 devices from conflicting with each other’s tasks. Maybe I’m wrong, but it’s working!

Answers

  • Olihop
    Olihop France - MontpellierMember Posts: 91 Tri
    edited February 28

    Hi,

    To configure your keyboard in midi mode you must assign it to the midi input of the sound you want to play. Sound > Input > MIDI > source (select the kk88)

  • Tiny Rivers
    Tiny Rivers Member Posts: 9 Sine

    Thanks! I’ve made a little progress, but I’m not sure where you are talking about sound>Input>MIDI>Source. Are you referring to a menu on the keyboard or a menu within Maschine? From which menu am I choosing “Sound >”?

  • Tiny Rivers
    Tiny Rivers Member Posts: 9 Sine
    edited February 28

    Ok so I figured out where the menu was that you were talking about. (Under the knob icon next to Master/Group/Sound.) Now when I go there my choices under source are only “none, default, host, focus”. Nowhere to choose kk88. Also not sure what to set “channel” and “thru” to. I feel like I’m so close. I just can’t get a clear picture of what I’m actually needing to do. Thank you so much for your patience.

  • Olihop
    Olihop France - MontpellierMember Posts: 91 Tri

    Then, your S88 keyboard must be running in MIDI mode for you to be able to select it from the source list.

  • Tiny Rivers
    Tiny Rivers Member Posts: 9 Sine

    I already have it in midi mode. It just doesnt pop up as an option in that pull down menu. 🤷🏻 I know my daw sees it because I can see pro tools flashing the chord names when I hit the keys. I’m so frustrated. Haha.

  • three_eyed_otter
    three_eyed_otter Keep San Antonio Lame... Member Posts: 21 Sine

    I hope this gets answered because I've wanted to purchase the KK M32 for a similar setup...Out of curiosity, have you followed the steps in 3.3.11 Using Two or More Hardware Controllers of the manual?

    Have a good one,

    3EO

  • Tiny Rivers
    Tiny Rivers Member Posts: 9 Sine

    Unfortunately in that section there is nothing about the Maschine Plus. So it’s kind of useless info for me in particular. I suppose I could do a trial and error thing with each process in case one of them works for the plus also, but I’m not confident.

    I’ve got a case going with someone at NI, if I get some answers I’ll definitely post them here!

  • Tiny Rivers
    Tiny Rivers Member Posts: 9 Sine
    Answer ✓

    Ok sooooooo….

    I have made it work!

    a few things… I’m used to the input/outputs that I have to deal with being the ones at the bottom of the track in the mix window. Things are different with this MIDI stuff. Forgive me for not knowing my way around all this yet. I’m just now getting into this MIDI stuff after 20 years of not messing with it!

    1. I had to toggle the MIDI OUTPUT SELECTOR at the top of the track in edit window to Maschine 2 MIDI Channel 1. (Appears that any of those channels will work at this point.)
    2. Arm track to Record. The Maschine Plus doesn’t care, but the KK88 needs the track armed for you to be able yo hear it.
    3. If the KK88 is not responding still, put the Maschine Plus in MIDI Mode (I had been trying to put the K88 in midi all this time.) Now you can uncheck Maschine Plus in the controller menu in Maschine. This should hand the controls back over to the KK88.
    4. Also when going into Maschine preferences, under “hardware,” KKS88 is still blank with no options, but I’ve found that if I select it, it sometimes kicks this all into place.
    5. As far as keeping all these things assigned to either KK88 or to Maschine Plus seems to work, but they also both seem to work sometimes without switching it over at all

    Like I said, I’m not sure what exactly I’ve done, but I DO know that I’ve got it working thru trial and error! So if this helps anybody….there ya go! If anyone knows exactly why this is working, feel free to fill us in. Mostly, it just seems like it was a matter of figuring out a way to keep the 2 devices from conflicting with each other’s tasks. Maybe I’m wrong, but it’s working!

Back To Top