Please be advised that due to scheduled infrastructure maintenance, we anticipate downtimes for the Native Instruments websites and Native Access on February 28, 2024 starting at 06:00 CET. For more details, click here.

how do i return / exchange a defective product

philJones
philJones Member Posts: 16 Member

I bought Machine Mk3 and it arrived a couple weeks ago and appears DOA. I have followed all the online trouble shooting and still it doesn't light up and is not recognized by the Machine 2 software. I also have not had any responce from hardware support. I don't know how to contact anyone regarding this.

Answers

  • Soutilé
    Soutilé Member Posts: 20 Member

    hi Phil,

    The staff usually quick to get back in touch. personal experience: I was getting irritated by my M32 ,not responding for a while.got in touch in touch with them. they ask me to install a software.

    next day ,while communicating over the phone, some nice French lad(STAFF), did it remotely, for me.

    it's DO ABLE remotely, keep on trying , check the SUPPORT section .

    get in touch, get an Automated Ticket , wait your turn , get it fixed remotely .

  • philJones
    philJones Member Posts: 16 Member

    Thank you for your answer. You have given me hope.

  • ShelLuser
    ShelLuser Member Posts: 240 Pro
    edited May 2023

    So.. important question: where did you buy the Maschine? May sound stupid but it's definitely needed to get some context for all this.

    As for troubleshooting... tried using the powersupply or do you only use the USB connection? That could be an issue. As for USB: what type of USB ports do you use? That can be another factor to consider.

    Also: did you make sure to provide all requested info on your profile? That can help staff on the forums to maybe look into this a bit more.

    (edit)

    As to contacting support... the answer is right above: click the support link and follow the provided steps.

  • philJones
    philJones Member Posts: 16 Member

    1) I bought it online direct from NI.

    2) I did go through the wizzard... three times in fact -- its been several weeks. Only got back the ticket number no follow up.

    3) did not purchase an off the shelf power supply because it is not supposed to be required and didn't want to void the warrenty

    4) tried 3 different PCs both usb 2 and usb 3 connections

    5) downloaded and installed Machine 2 and everything it reports the correct drivers and works fine.

    6) checked all the drivers on the pc they are up to date.

    7) all the ni services are running.

    Its not software, its not usb ports or cables.... its the controller.

    Any suggestions .... you are the first that has responded with help.

  • LostInFoundation
    LostInFoundation Member Posts: 4,004 Expert

    From all the info you provide, it really seems like you received a defective product, if it, as you say, doesn’t even light up, presuming you mean it doesn’t even have any sign of life, not that it is in this state and only the connection to software doesn’t work:






    If on the other hand it is on this state, we can work on it and try to find a solution.

    But if it doesn’t light up, I’m afraid you’ll have to wait for the support answer to have a substitution (and in these days they have a lot of requests (and probably they are underemployed) and therefore they are slow)

    One last suggestion to see if the device isn’t working at all: open Controller Manager and check if it is recognized there. But it not lighting up at all doesn’t sound like a good sign

  • philJones
    philJones Member Posts: 16 Member

    thanks for your reply.

    The controller doesn't boot. It never has. I'm hoping to fix or replace it.

    The first support request I made was on fri. May 12th.

    Thats 13 days without an answer. I must be doing something wrong.


    That is why I reached out in this forum.

  • D-One
    D-One Moderator Posts: 2,722 mod

    Can you check in windows device manager if you see anything with an escalation mark?

    By 'boot' do you mean you don't see the Maschine logo on the screen like in @LostInFoundation 's picture? It doesn't do the light/color show when you plug in a USB? If that's the case then it really prob is DOA.

    Which support section did you contact the generic one or the Hardware specific one? Whats your ticket #? Often @Jeremy_NI is able to follow up tickets that get lost for some reason.

  • LostInFoundation
    LostInFoundation Member Posts: 4,004 Expert

    You are not doing anything wrong. I have a ticket opened from the 12th too and still waiting. They are just slow these days

  • Jeremy_NI
    Jeremy_NI Customer Care Posts: 8,861 mod

    @philJones I found your tickets and escalated them. Hopefully someone gets back to you soon.

  • philJones
    philJones Member Posts: 16 Member

    thank you sooo.... much!

Back To Top